Bug #21176

No upload in the new massuploader with Firefox

Added by Philipp Holdener over 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-10-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The new massupload tool doesn't work in Firefox (newest version on mac).
I got a message that 100% is uploaded and the massupload toll has closed .. but no files are on the server after that.

With Safari or IE everything works fine. I can upload files without problems.

(issue imported from #M12103)


Related issues

Related to TYPO3 Core - Bug #20979: PHP warning in file module when uploading files with the flashuploaderClosedRupert Germann2009-09-02

Actions
Related to TYPO3 Core - Bug #21916: files upload through Firefox 3.5.6ClosedSteffen Gebert2010-01-06

Actions
Related to TYPO3 Core - Bug #21920: Improve error handling of massuploaderClosedBenni Mack2010-01-06

Actions
Related to TYPO3 Core - Bug #22185: Flash Uploader not working in FF, SF and Iron when Tortoise SVN is installedClosedSteffen Gebert2010-02-25

Actions
Related to TYPO3 Core - Bug #22622: No upload in the new massuploader with Firefox and using self signed SSLClosedChris topher2010-05-10

Actions
#1

Updated by Philipp Holdener over 11 years ago

I have no log entry in TYPO3 for this wrong upload. With Firefox on windows I got a log entry that a file is uploaded.

#2

Updated by Steffen Gebert over 11 years ago

l think even with shared hosting you should have access to the server's access and error. Please attach the corresponding snippets.

Can you reproduce the problem on a different typo3 installation or with a different mac?

#3

Updated by Philipp Holdener over 11 years ago

Thought you have the same problem like you said in the list? But strange is, same FF Version, same Mac os x on an other mac --> the uploader works there! hmm...

There are NO log entrys the server support said for the uploads on the other mac. No error is shown. The uploader said everything is fine - but no files on the server. Hm, don't know whats the problem on this Mac!? :-( .. I deinstalled several plugins on the Firefox -- same problem still exists.

#4

Updated by Oliver Hader over 11 years ago

Are you always uploading to the same server?
How big is the file? Does it work with smaller files?
Which version of the Flash plugin do you use?

I don't have any problems with FF 3.5.3 on Mac OS X Snow Leopard...

#5

Updated by Philipp Holdener over 11 years ago

the size of the file makes no difference... but, I have testet it on an other server. There everything works fine! Don't know why it isn't working at this server! :(
I have no special extensions... both installations have the same!

#6

Updated by Oliver Hader over 11 years ago

Ok, please disable the flashuploader and test it again:
In "User Settings" module on tab "edit & advanced functions", disable the checkbox for "Enable Flash Uploader (requires Flash 9+)"...
Then we know if the upload fails in general or if the issue is related to the mass file uploader only.

#7

Updated by Philipp Holdener over 11 years ago

Works fine if a disable the checkbox! Only with the flashuploader no upload is possible.

#8

Updated by Staffan Ericsson over 11 years ago

I have the same problem. Using Win7, Firefox 3.5.3, Flash 10.0

The upload fails in the flash uploader and works perfectly without flash.

When I tried a larger file I got a delay and clicking cancel crashed Firefox for me.

#9

Updated by Steffen Gebert over 11 years ago

I just tried it using exactly this combination and it worked, of course.

There seem to be weird problems out there :(
Can you reinstall firefox/flash?
Could you provide a tcpdump/wireshark dump of the upload?

But I admit: FF also hung up once, while opening the "Select file(s) to upload" dialog

#10

Updated by Kay Strobach over 11 years ago

i have the same problem with firefox 3.5.5 and current safari on windows 7.

i made a short video with camtasia studio, because i saw an error message some milliseconds which rapidly disapperes

Internal Error: Problems while reading/writing the file

I tried to upload a file from a folder on my desktop and from folders on a different drive. Upload without flash works perfectly

-> Upload with Internet Explorer 8 works, from the same machine, where safari and firefox failed. Internet Explorer throws an UAC Message because of installed tortoise SVN! -> perhaps thats the problem?!

->You won't believe, after uninstalling tortoise SVN everything works fine in Firefox and Safari.

-> Scary, isn't it?

-> So i've downloaded and installed Tortoise SVN again, and got the same behavior after reboot. (TortoiseSVN-1.6.6.17493-win32-svn-1.6.6)

Best Regards Kay

#11

Updated by Kay Strobach over 11 years ago

After quite a while of testing a found the following way to get the upload working (on windows 7 and firefox and safari):

switch ;)
Case 1:
Uninstall Tortoise SVN

Case 2:
open internet explorer, make minimum one upload with flashupload and agree to the UAC question regarding tortoise SVN
open any other browser and upload as many files as you wan't

=> I assume, the the flashplayer in IE asks for permissions, which it does not in other browsers?!

with the hope of a real fix - Best Regards

Kay

#12

Updated by Staffan Ericsson over 11 years ago

Seems that a note about the behaviour should be added to the upload page or settings page.

#13

Updated by Staffan Ericsson over 11 years ago

Kay: Tryied Case 2 without success :-(

#14

Updated by Kay Strobach over 11 years ago

what version of windows etc. are you using?

i use the
windows 7 ultimate
latest tortoise svn
internet explorer 8
firefox 3.5.5

The upload MUST be done to the same server in IE and FF.

This behaviour is reproducable on my system. -> No idea what happens on your system. Do the uploads in IE succeed?

================================

there must something like an alert, if the upload fails AND even if flashupload is enabled, it should be possbible to use the normal upload from the same popup -> i like the solution i've seen in wordpress, the user can easily swith directly from the upload dialog.

BTW is the flashuploader also available in tceforms? - i do only have the classic one ;)

#15

Updated by Staffan Ericsson over 11 years ago

I unsinstalled tortise svn and no sucess.

I use Win7 Pro x64 with Fx 3.5.5. (fully patched)

Could the diffrence be that I use HTTPS?

.staffa

#16

Updated by Kay Strobach over 11 years ago

mhmm i use win 7 ultimate 32bit and http only
thats of course a difference

do you have any other windows explorer extensions?

test report:
windows xp 32bit professional is working perfectly
windows vista 32bit home premium firefox is working perfectly
windows seven 32bit ultimate see problems above

> so it seems to be an windows 7 and firefox/safari with flashplayer issue
> i haven't programmed flash in the last years, so i can't provide any additional ideas how to solve this problem

Best regards Kay

#18

Updated by Kay Strobach over 11 years ago

what about implementing it using http://typo3.org/extensions/repository/view/ameos_dragndropupload/current/ as base, i think java is nearly spread as wide as flash and it is working ...
I use this extension quite for a while now and it's working perfectly, the only problem is, that it adds a new BE Module, and doesn't integrate directly into the filelist module.

best regards

Kay

#19

Updated by Andreas Ofner over 11 years ago

Hello,

I would mention the following ...

There are several sources of error (JS / Flash / PHP / Apache Settings)
when using such a complex component.

I tried the "mass file upload" in an TYPO3 4.3-RC2 Installation.

My Config:
- Mac OS 10.5.8
- Shockwave Flash 10.0.32.18

Test Setup I:
- FF 3.5.5 (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5)
-> it works fine!

Test Setup II:
- Safari Version 4.0.4 (5531.21.10)
-> it works fine!

But in my first approach using TYPO3 4.3-RC2 - a Testproject with HTTP-Auth activated via .htacces File in the Root Folder
-> The File upload does not work - I got the Status Message "Too many Files selected" for each Image.

#20

Updated by Steffen Gebert over 11 years ago

Yes, I also experienced this with HTTP-Auth.
On Windows, Flash asks for the password - on other platforms it doesn't.
Don't know, weather we could have better error messages.

#21

Updated by Steffen Gebert over 11 years ago

I've just searched a bit. HTTP-Auth seems to be problematic with Flash. This also stated in the known-issues section of swfupload.

There seems to be no (easy) way (for us), to change this.

What you could do to protect your dev-site AND use the uploader is to exclude .htaccess protection for POST requests (may be only on ajax.php).

#22

Updated by Kay Strobach over 11 years ago

the described problems with win7 where with sites, which do NOT have any .htaccess restriction.

#23

Updated by Steffen Gebert over 11 years ago

Do you use HTTPS and self-signed certificates?

It works for me, when I use HTTP or a vhost with a valid SSL certifcate.

It does NOT work with a self-signed certificate.
I think this is because Flash doesn't use the browsers list of accepted certificates, but uses own validation. Will do some research.

Would be great, if you could approve/rebut my experience+theory.

#24

Updated by Staffan Ericsson over 11 years ago

I use a certificate that does not cover the current typo3 domain. So the theory that Flash uses an internal SSL certifcate list.

#25

Updated by Steffen Gebert over 11 years ago

http://code.google.com/p/swfupload/issues/detail?id=201

EDIT: allowInsecureDomain seems only to allow access to a HTTP domain, while the flash being loaded via HTTPS - and not to ignore SSL-validation errors.

EDIT 2: http://code.google.com/p/swfupload/issues/detail?id=27 thats the correct issue

Any flash guru here?

#26

Updated by Steffen Gebert over 11 years ago

After some further research and a short chat with Benni:

  • Flash can't handle self-signed SSL certificates
  • Flash seems to use the certificates from IE sometimes (IE7+8 work for me), so it might be able to work there
  • You can't neither accept certificates in flash nor add trusted ones
  • You can't do .htaccess authentication
  • Flash is really ugly..
  • We need a better error message (telling the user that he should disable uploader, because there are problems). This is a job, which might be done by swfupload developers, but I think we have no time to wait.
  • It should be easier to use a fall-back solution uploader (checkbox to disable it in-place instead of in user settings?)
  • Can we have a better fall-back then the "old" uploader? ExtJS?
  • Can we detect, weather we are coming from a self-signed SSL site and disable ourself? (would be to nice to be true..)

Better error message + easier way to disable uploader IMHO for 4.3.1

#27

Updated by Tempestini Cédric [Archriss] over 11 years ago

Up ! Same problem with firefox, IE7, google chrome on windows, but no probem on mac OS...

#28

Updated by Steffen Gebert over 11 years ago

Could you please try this patch and give feedback, whether it gives you a reasonable error message?

http://bugs.typo3.org/file_download.php?file_id=9840&type=bug

#29

Updated by Steffen Gebert over 11 years ago

As #21920 added an improved error handling for the uploader (included in 4.3.2), we should cover the most frequent pitfalls and provide explicit error messages.

If you still encounter problems, please provide as much information as possible about your environment.

Also available in: Atom PDF