Bug #22185

Flash Uploader not working in FF, SF and Iron when Tortoise SVN is installed

Added by Kay Strobach almost 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2010-02-25
Due date:
% Done:

0%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This Problem is related to #0012103

The Flashuploader works in WinXP with IE6
The Flashuploader works with IE8 on Windows 7 (with UAC Warning because of Tortoise SVN).
But it doesn't work on FF3.6 and Iron 4.x (resp. Chrome 4.x) and Safari.

There is no error message:

1. Window occurs to select message
2. Hit select files button
3. select on file
4. Press Open
5. 100% occurs
6. automated reload
7. can't find file in ff, iron, safari :(

I use TYPO3 4.3.2 on Solaris with Apache2.

Best regards
Kay

Perhaps http://www.plupload.com/example_all_runtimes.php is the correct way. It's a library which supports different types of upload environments with the same visual representation. The examples on that page worked like a charm ...

Best regards
Kay
(issue imported from #M13659)

T3X_plupload-alpha1.t3x (260 KB) Administrator Admin, 2010-02-28 16:56


Related issues

Related to TYPO3 Core - Bug #21176: No upload in the new massuploader with Firefox Closed 2009-10-02
Related to TYPO3 Core - Bug #23419: Flash uploader doesn't work with cookieHttpOnly Closed 2010-08-22
Related to TYPO3 Core - Bug #23521: Flash Uploader does not work if cookieHttpOnly is enabled Rejected 2010-09-09

History

#1 Updated by Kay Strobach almost 10 years ago

in ubuntu with firefox 3.5.3 i'll get an error 303 message box in the browser window

All of your uploads failed.

If this problem persists, please try another browser, contact your administrator or disable this "Flash Uploader" in your User Settings.

Detailed problem description:
303

<<<

#2 Updated by Kay Strobach almost 10 years ago

i'm working on an uploader extension base on www.plupload.org

PLupload makes it possible to use gears, html5,flash or silverlight as upload lib.

I add the code as zip to this report, perhaps it'll be integrated in the core ;)

#3 Updated by Kay Strobach almost 10 years ago

the extension needs to be installed locally, i haven't included path corrections for global install

#4 Updated by Chris topher over 9 years ago

Hi Kay,

you wrote in #21176 (Note 0032304) that you could solve this for Firefox and Safari by uninstalling Tortoise SVN.
Another way was to let Tortoise SVN installed and first do one upload with IE to the problematic server (confirm the UAC warning of Tortoise SVN while doing this). After that uploading with other browsers worked.

Somehow the UAC warning in IE seemed to "fix" the problem for IE.
In Firefox and Safari there was no warning and it didn't work there.

Any ideas?

PS: Was it working in 4.3.1 or 4.3 (because you report it for 4.3.2)?

#5 Updated by Christian Nölle over 9 years ago

Can confirm this with FF 3.6.4, TYPO3 4.4.0 and Tortoise 1.6.9 Build 19725 for x64-Systems installed. Using Chrome, everything is fine!

#6 Updated by Steffen Gebert over 9 years ago

This sounds really weird, with the UAC. Don't know, why the Flash Uploader causes a problem with Tortoise.
It's based on swfupload, maybe you can have a look at their bug tracker? http://code.google.com/p/swfupload/issues/list

Just tried it on XP, but there's no problem. Have no UAC aware system here. Kay, do you also have x64?

#7 Updated by Kay Strobach over 9 years ago

i used an x32 windows 7 business professional.

perhaps plupload is an solution.
i still had problems in 4.3.
But didn't tested it in 4.4.

I found plupload very usefull.

-> I made an example extension with plupload, if interested, i can provide it as download here...

#8 Updated by Patric Pesch over 9 years ago

I use win XP x32 at work and have the same problem, but i have no Tortoise SVN installed. The upload only works with IE 7 & 8. I've tested now any browser on various machines (win XP, Win Vista x32 & x64, Win 7 x64, Ubuntu x64), and none of them works.
Browsers i've tested:
Chrome 6.0.447.0
Opera 10.60
Firefox 3.6.6 & 3.6.3
Safari 5.0
Shiretoko 3.5.9 (FF on ubuntu)

Forgot to mention: I tried it with TYPO4.3 and 4.4 (both with clean installs)

#9 Updated by Kay Strobach over 9 years ago

so in my opinion its time to let swfupload die and give plupload a try.

sure there need to be a lot of pros, why should we change the library:
1. progressive/chunked uploads if env supports it
2. html5,gears,yahoo,silverlight as upload engine
3. autoselection of upload engine
4. partial dragndrop support (depends on env)
5. works well clear error messages
6. Opensource

additionally it would be nice to have a hook in the filelist to modify the buttons on top, to integrate own uploaders or other tools

best regards kay

#10 Updated by Patric Pesch over 9 years ago

hi, after hours i've found the reason for my upload problems. I am not sure, if it helps everybody or if it is an obvious stupidity by myself.

I did a clean install indeed, but i used an own dummy with some presettings. Among others with the setting "['cookieHttpOnly'] = true;"

With this setting flash (or the JS) wasn't able to process the cookie and failed.
Without cookieHttpOnly, everything works fine.

#11 Updated by Tobias Liebig over 9 years ago

i can second patrics issue.
I disabled the cookieHttpOnly setting for the Backend using these lines in the localconf.php:

$TYPO3_CONF_VARS['SYS']['cookieHttpOnly'] = '1';
if (TYPO3_MODE == 'BE') {
$TYPO3_CONF_VARS['SYS']['cookieHttpOnly'] = '0';
}

So, cookieHttpOnly is enabled for the FE at least.

#12 Updated by Steffen Gebert over 9 years ago

Of course, this sounds very reasonable!

#13 Updated by Steffen Gebert over 9 years ago

Kay, do you have cookieHttpOnly set?

@Patric
it's not your stupidity, but a very useful hint to understand the bug with the uploader! Thanks!

#14 Updated by Steffen Gebert over 9 years ago

Kay, any feedback?

#15 Updated by Steffen Gebert over 9 years ago

I've created a new report for the cookieHttpOnly problem, as I'm unsure, if the initially problem of this report is caused by the same setting.

See #23419

#16 Updated by Kay Strobach about 9 years ago

sry, mail got missing:

cookieHttpOnly was not set. - seems to be a coupleof problems with firewall / flash / and non privileged user

#17 Updated by Kay Strobach about 9 years ago

currently the flashuploader is not working for me 4.5beta3
(do i need to change a setting to get the pluploader instead of the old one?)

#18 Updated by Stefan Galinski about 8 years ago

  • Target version deleted (0)

Hi Kay,

Is this still a problem since the new uploader was integrated?

#19 Updated by Lorenz Ulrich over 7 years ago

For me the Flash uploader works, it only doesn't work when cookieHttpOnly is set, but for there is another issue for that. I have TortoiseSVN installed and am working with Firefox.

So it might be closed.

#20 Updated by Steffen Gebert over 7 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee set to Steffen Gebert

Thanks for your feedback.

Also available in: Atom PDF