Bug #21625

Section links coming from RTE broken in FE: rendered as #14185& instead of #c123

Added by Uschi Renziehausen almost 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Communication
Target version:
-
Start date:
2009-11-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
If you enter a link to a specific CE via RTE the href-attribute points to a nonexisting id. Instead of #c123 you get #14185& in FE.

When you first enter the link in RTE, the href looks like this:
<a class="internal-link" href="http://gift.uni-erfurt.t3/?id=512#14185&">
In DB the link looks like this:
<link 512#14185& - internal-link>
And FE:
href="/area-51/bilder/bilder-im-rahmen/#14185&"

Uschi

(issue imported from #M12682)


Files

typo3core_bugfix_12682_trunk_v2.patch (6.11 KB) typo3core_bugfix_12682_trunk_v2.patch Administrator Admin, 2009-12-01 19:59
typo3core_bugfix_12682_typo3_4-3.patch (6.11 KB) typo3core_bugfix_12682_typo3_4-3.patch Administrator Admin, 2009-12-01 20:00

Related issues

Has duplicate TYPO3 Core - Bug #21778: Enabling internal query parameters ruins links with anchorsClosedStanislas Rolland2009-12-02

Actions

Also available in: Atom PDF