Bug #21873

alternative page language will be deleted in new workspaces after publishing

Added by Marcel Fiedrich about 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-12-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

if I published an alternative page language that I have created in a new created workspace the record will be deleted.

(issue imported from #M13075)


Files

13075-versionswap-alternativepage.patch (687 Bytes) 13075-versionswap-alternativepage.patch Administrator Admin, 2010-03-07 15:47

Related issues

Related to TYPO3 Core - Bug #22034: Recursive deletion of alternative page languagesClosedAndreas Otto †2010-01-31

Actions
Is duplicate of TYPO3 Core - Bug #22281: tcemain versionSwap might break pages_language_overlay relationsClosedSusanne Moog2010-03-15

Actions
#1

Updated by Marcel Fiedrich almost 12 years ago

I've tested this issue again in a fresh installed TYPO3 Backend (Ver. 4.3.1).
I've created a new alternative page language in the Draft system-workspace and tried to swap the versions.
after i have clicked the swap-button the page is deleted.

#2

Updated by Marcel Fiedrich almost 12 years ago

I have fixed the bug.
In /t3lib/class.t3lib_tcemain.php on line 4730 the "transOrigPointerField" will be kept.
That's ok if it's the l18n_parent field, but for the "pages_language_overlay" table is it the "pid"-Field.
If you publish/swap a page overlay record, the pid field will always change to -1.

so I have changed the if-construct from:

if ($TCA[$table]['ctrl']['transOrigPointerField'])
to:
if ($TCA[$table]['ctrl']['transOrigPointerField'] && $table != 'pages_language_overlay')
or to:
if ($TCA[$table]['ctrl']['transOrigPointerField']!='pid')

I think both ways should work.

#3

Updated by Christian Hennecke almost 12 years ago

I can confirm this. It's 100% reproducable here and is giving my editors a hard time.

#4

Updated by Darren Clark almost 12 years ago

Confirmed that the problem exists with 4.3.2

Uploaded patch 13075-versionswap-alternativepage.patch fixing the issue against the TYPO3_4-3 branch.

#5

Updated by Noel Bossart almost 12 years ago

I have the same Issue on 4.3.3 dev!
This should be a Major issue since content gets lost!

#6

Updated by Felix Buenemann almost 12 years ago

I'm also seeing this issue on 4.3.2. Upon publishing changes to the page overlay pid field in pages_language_overlay changes to -1 instead of the correct page id and thus content vanishes from view.

The patch 13075-versionswap-alternativepage.patch solved the issue on 4.3.2.

#7

Updated by Stefan Terborg almost 12 years ago

The pathc worked for me on 4.3.2. Thank you very much.
But:
on 4.3.3 this problem occurs again. I think the patch does not work there.

#8

Updated by Tolleiv Nietsch almost 12 years ago

this is a duplicate of #13818 which is already pending in the core-list and waiting for review

#9

Updated by Darren Clark almost 12 years ago

Confirmed that the patch 13075-versionswap-alternativepage.patch still successfully fixes the issue against Typo3 4.3.3

#10

Updated by Philippe Moreau over 11 years ago

Confirming the patch to also work with 4.3.0.
This issue should probably be labeled as major.

#11

Updated by Chris topher over 11 years ago

Hi guys,

please have a look at the thread for #13818 in Core List!

Tolleiv already posted his patch there. But it will not be integrated if not anyone gives his +1 on reading and testing.

Also available in: Atom PDF