Bug #22445

impexp: doesn't work when used from clipboard in list module

Added by Irene Höppner about 11 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-04-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Some kind of hidden ;-) but nice feature isn't working anymore:
If you activate the clipboard, use clipboard #1 (or #2 or #3) then you can add a bunch of record to this clipboard. Then you can use the [Menu]-select-box to export this records to a .t3d-file.

This doesn't work anymore since version 4.3.
The error-message is:

Value "xMOD_tximpexp" for "M" was not found as a module

(issue imported from #M14095)


Files

14095_v1.diff (1.15 KB) 14095_v1.diff Administrator Admin, 2010-06-09 17:28
14095_v2.diff (1018 Bytes) 14095_v2.diff Administrator Admin, 2010-07-15 13:30
T3X_fixclipexport-0_0_0-z-201009151607.t3x (3.52 KB) T3X_fixclipexport-0_0_0-z-201009151607.t3x Administrator Admin, 2010-09-15 16:08

Related issues

Related to TYPO3 Core - Bug #22495: Export clickmenu item links to absolute path inside Web > PageClosed2010-04-21

Actions
#1

Updated by Sebastian Michaelsen about 11 years ago

Also stumbled over this bug today..

#2

Updated by Peter Niederlag about 11 years ago

funny, this pops up again, as this must have been broken for quite some time ...

#3

Updated by Peter Niederlag about 11 years ago

IMO this bug was introduced by revision 1965 in February 2007 and can safely be fixed by reverting that change, see attached patch

#4

Updated by Bernhard Kraft almost 11 years ago

I uploaded a diff against latest TRUNK

#5

Updated by Bernhard Kraft almost 11 years ago

I uploaded an extension "T3X_fixclipexport-0_0_0-z-201009151607.t3x" which fixes this problem via XCLASS if you do not have access to modify the T3 source in an installation.

#6

Updated by Felix Nagel over 10 years ago

I can confirm this bug. Patch is provided since a few month -- Please fix this soon!

#7

Updated by Mario Rimann over 9 years ago

I just tested this one against the current version from Git (4.7-dev) and can't reproduce this issue. Also the patch that is attached can't be applied -> exactly those changes seem to have been integrated already. Couln't figure out when exactly this has been integrated...

#8

Updated by Felix Nagel over 9 years ago

Confirmed, issue seems to be solved in TYPO3 4.5.6

#9

Updated by Xavier Perseguers over 9 years ago

  • Status changed from Accepted to Closed
  • Assignee deleted (Peter Niederlag)
  • Target version deleted (0)

Since it is fixed in 4.5 LTS, we won't loose time for older deprecated branches.

Also available in: Atom PDF