Bug #22871

Handling of <span> tags and span.rmTagIfNoAttrib = 1

Added by Graham Knight about 12 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-12
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I am using TYPO3 4.2.12 with rtehtmlarea 1.7.14.

I have this in my Page TSConfig:

  1. Clear everything to start with
    RTE.classes >
    RTE.default >

RTE.default { # Specify the buttons to be used and their layout
showButtons := addToList(chMode)

proc {      
overruleMode = ts_css
allowTags = span
entryHTMLparser_db = 1
entryHTMLparser_db { ## TAGS ALLOWED
allowTags < RTE.default.proc.allowTags
tags {
span.rmTagIfNoAttrib = 1
}
}
}
}

In text mode in the RTE I enter:

<p><span class="foo">Hi there</span></p>

and save it. This works fine - no changes. However, if I enter:

<p><span>Hi there</span></p>

and save it then in Firefox 3.6.3 everything appears fine but in IE 8.0 I get:

<p>Hi there</span></p>

In fact, if I save with Firefox and then read back with IE I get the same effect. So it looks to me that the same error occurs for each browser when saving to the database but that Firefox cleans things up on the way back.

Stanislas advised:

Use:
allowTags = span, p

However, there is a problem in the html parser as the result in the
database is

Hi there</span>

Please report the issue in the bugtracker.

Using
...
tags {
span.rmTagIfNoAttrib = 1
span.nesting = 1
}

will work around the issue.

This worked for me!
(issue imported from #M14710)


Related issues

Is duplicate of TYPO3 Core - Bug #50144: HTMLParser does not remove end tag when applying rmTagIfNoAttribClosedStanislas Rolland2013-07-18

Actions

Also available in: Atom PDF