Feature #22985

filter page tree by page uid

Added by Stano Paska over 8 years ago. Updated 10 months ago.

Status:
New
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2010-06-24
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:
Remote Sprint

Description

Sometimes I need locate page in page tree by uid, not only by page title.
This small patch adds described functionality.

(issue imported from #M14851)

tree.js.patch View (987 Bytes) Administrator Admin, 2010-06-24 13:24

17.png View (73.9 KB) Sybille Peters, 2018-05-23 13:19


Related issues

Related to TYPO3 Core - Feature #36075: Advanced Filtering for the Page-Tree New 2012-04-14

History

#1 Updated by Riccardo De Contardi almost 6 years ago

  • Target version deleted (0)

both in TYPO3 CMS 4.5.20 and 6.1.0 if you click the pagetree filter and enter an ID (e.g. "50"), it works.
But if you have "50" as text in the pagetitle ("50 shades of grey" - LOL) it will be found ,too.

IMHO should be more nice if you could use an expression like:

id:50

#2 Updated by Mathias Schreiber about 4 years ago

  • Description updated (diff)
  • Assignee set to Mathias Schreiber
  • Sprint Focus set to Remote Sprint

#3 Updated by Daniel Goerz over 3 years ago

Can we close this one? Searching by ID is already possible and I dont consider it a bug that a page with "50" in its title is found if one searches for "50". A construct like id:50 is not desireable at all, as it is unintuitive and bad in terms of usability.

#4 Updated by Stano Paska over 3 years ago

Yes, you can close this one. Thank you.

#5 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Closed

functionality already present. Closed.

#6 Updated by Sybille Peters 10 months ago

  • File 17.png View added
  • Category set to Backend User Interface
  • Status changed from Closed to New
  • PHP Version deleted (5.2)

I would like to reopen this.

AFAIK, the current behaviour if you use "Filter Tree" and use a number num, you get a list of pages including:

  • page with page id= num
  • pages which have num in their title
  • others ... ?

Additionally, it would be useful to be able to filter by specific page id only.

Yes, this is not a bug. Correct. But this issue was opened as feature. If you don't agree or there is some other way to do this, please close again.

I like Riccardo's suggestion but any other way to do this would be fine with me too.

Example Usecase:

In an installation (TYPO3 8) with about 30000 pages, I want to filter by page uid=17. This gets me a huge number of results, including any page with 17 in the title.

This is not a theoretical usecase, but something which has happened to me a number of times, I find it annoying and it complicates the workflow.

Please regard the scrollbar. What you are seeing here is just a subset of the found pages. Page uid=17 actually exists.

#7 Updated by Riccardo De Contardi 6 months ago

  • Related to Feature #36075: Advanced Filtering for the Page-Tree added

Also available in: Atom PDF