Project

General

Profile

Actions

Bug #23255

closed

Menu 'special.updated' > property beginAtLevel = 1 seems ignored

Added by Falk no-lastname-given about 14 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Frontend
Target version:
-
Start date:
2010-07-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Remote Sprint

Description

The following TEMNU - config width beginAtLevel = 1 even displays the under value defined "starting-page" (PID: 23).

tmp.menu = HMENU
tmp.menu {

special = updated
special.value = 23
special {
mode = tstamp
beginAtLevel = 1
depth = 2
maxAge = 3600*24*3000
limit = 80
}
1 = TMENU
1 {
NO.linkWrap = |<br />
}
}

(issue imported from #M15214)

Actions #1

Updated by Alexander Opitz over 10 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

Actions #2

Updated by Falk no-lastname-given over 10 years ago

Hi, the Problem is in 4.5.30 still present. I've at the moment no possiblity to check this in 6.1.

Btw. "beginAtLevel = 2" works well and only "beginAtLevel = 1" makes trouble.

Actions #3

Updated by Alexander Opitz over 10 years ago

  • Status changed from Needs Feedback to New
Actions #4

Updated by Mathias Schreiber over 9 years ago

  • Assignee set to Benni Mack
  • Target version set to 7.2 (Frontend)
  • Sprint Focus set to Remote Sprint
Actions #5

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
Actions #6

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #7

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #8

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
Actions #9

Updated by Riccardo De Contardi over 8 years ago

  • Subject changed from Menu 'special.updated' with beginAtLevel = 1 works not as expected to Menu 'special.updated' > property beginAtLevel = 1 seems ignored
  • Category set to Frontend

Still true for both 6.2.16 and latest master (8.0-dev)

Tested with the provided code; the test fails because the starting page special.value = X is still present in the menu, despite the special.beginAtLevel = 1

Actions #10

Updated by Gerrit Code Review over 5 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60462

Actions #11

Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61175

Actions #12

Updated by Benni Mack about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #13

Updated by Benni Mack about 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF