Bug #24737

backend_layout not workspace compatible

Added by Tolleiv Nietsch over 8 years ago. Updated 3 months ago.

Status:
Under Review
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-01-23
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If a backend_layout record is created in a workspace the select-fields on the pages don't show the records.

And switching to the live workspace shows the (workspace-only) backend_layout records in the dropdowns.

Might be a TCA configuration issue (foreign_table_where considering workspaces?) - had no time to have a deeper look / sry.

(issue imported from #M17227)


Related issues

Related to TYPO3 Core - Bug #27811: Page-view in backend uses "backend-layout"-field from live-version instead of workspace Closed 2011-07-02

History

#1 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change Id8a9f703db2ef028f529bd363a759721e7298e03 has been pushed to the review server.
It is available at http://review.typo3.org/3392

#2 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/3392

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/3392

#4 Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/3392

#5 Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/3392

#6 Updated by Oliver Hader over 6 years ago

  • Status changed from Under Review to Needs Feedback
  • Target version deleted (0)

Is this issue still valid?

I yes, please give a step by step description on how to reproduce. I could not reproduce it in current master (6.1-dev) with the mentioned backend layout field.

#7 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

#8 Updated by Stefan Neufeind about 6 years ago

  • Status changed from Closed to Under Review

I just tested this on current master (6.2). Inside the workspace I see the newly created backend_layout on a page immediately. But going back to the live-workspace there it also appears though it hasn't yet been published.

Could it be that BE-layouts aren't versioned (anymore) but meanwhile always created in the Live-WS directly? Please note though that this was originally reported against 4.5, where the situation might have been different.

#9 Updated by Stefan Neufeind almost 5 years ago

  • Is Regression set to No

@Olly (and others): Just tried it again and the issue still exists on current master.

How to reproduce:
  • Have a page
  • Have a workspace besides "Live".
  • Create a backend-layout in Live.
  • See that this backend-layout appears in the dropdowns for Live.
  • Change to the other workspace.
  • Create an additional BE-layout there.
  • See that in the page-details inside the workspace the new layout appears.
  • Change to Live again. See page-details.

Error: In the Live-workspace you now see two additional BE-layouts in the dropdown. The one created inside the additional workspace as well as the placeholder (I guess) from Live.

#10 Updated by Stefan Neufeind almost 5 years ago

  • Status changed from Under Review to Accepted
  • TYPO3 Version changed from 4.5 to 6.2
  • PHP Version deleted (5.2)

I don't think we'll fix this for below 6.2 anyway. And the solution currently under review didn't work on master. So we'll need to find a different way to fix this.

#11 Updated by Riccardo De Contardi almost 4 years ago

It is still present in both 6.2.15 and 7.5-dev (latest master).
See comment #9 about how to reproduce and the results.

#12 Updated by Riccardo De Contardi over 3 years ago

  • Category set to Workspaces

#13 Updated by Riccardo De Contardi 8 months ago

still present in 8.7.20

#14 Updated by Gerrit Code Review 3 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60501

#15 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60501

Also available in: Atom PDF