Bug #25164

Copy & Paste: "Validating the security token of this form has failed. Please reload the form and submit it again."

Added by Markus Kappe almost 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This error occurs when you got the extension kb_conttable installed (tested 0.4.0)
Related to #24963.

Bugfix: append token:
class.ux_t3lib_clipboard.php : 118 (function pasteUrl)
'&CB[pad]='.$this->current.t3lib_BEfunc::getUrlToken('tceAction');

(issue imported from #M17748)


Related issues

Related to TYPO3 Core - Bug #24671: Protect C(R)UD actions against CSRFClosedErnesto Baschny2011-01-20

Actions
Related to TYPO3 Core - Bug #25359: Essential form protection tokens are dropped when beeing logged in for a "long" timeClosedHelmut Hummel2011-03-20

Actions
#1

Updated by Torben Aschmons almost 11 years ago

Same with Extension kb_tv_cont_slide (0.4.3).

#2

Updated by Markus Klein almost 11 years ago

All of these extension do some kind of XCLASSing.
So this issue can only be fixed in the extension.

Unfortunately Bernard Kraft, the extension author, recently announced, that he stopped working on TYPO3 completly. So no idea who'll be fixing this.
(He also mentioned that he will sell his rights on the extensions, so maybe there's already a new maintainer.)

#3

Updated by Arek van Schaijk over 10 years ago

"Validating the security token of this form has failed. Please reload the form and submit it again."

This error occurs when I save a page, CE or a TS template. I have the problem on a new 4.5.2. The following extensions are installed;

- templavoila
- PhpMyAdmin
- Quixplorer

I don't installed 'kb_' extensions yet.

#4

Updated by Markus Klein over 10 years ago

Guess it is a templavoila problem.
Did you clear all caches (incl. your browser's)?

If so, then please report this to templavoila project.

#5

Updated by Arek van Schaijk over 10 years ago

Does TemplaVoila also render template records when you edit and save it in the list mode?

I want to say that the error does not always occurs. Sometimes it reports three times the same error after saving a record.

I cleared all caches (incl. browser's).

#6

Updated by Markus Klein over 10 years ago

It's really hard to track down a problem, if it only occurs randomly.
If this is really a Core issue then this error must occur on any record type you edit.

Btw.: Yes it is strange that this also happens with template records, but templavoila is also hooked into processDatamapClass and processCmdmapClass so maybe it has something to do with this.

It's out of my scope now, since im not really into TemplaVoila.

Maybe you can try removing TemplaVoila and check if editing a template record is working then.

#7

Updated by Arek van Schaijk over 10 years ago

When viewing the admin functionality "Reports", the error occurred again (for once):
Screenshot: https://www.ucreation.nl/typo3stuff/error-at-reports.png

This is another Typo3 4.5.2 installation than the installation where I had problems already.

#8

Updated by Markus Klein over 10 years ago

Sorry I can't help you further this way.

Please enable BE debugging: $TYPO3_CONF_VARS['BE']['debug'] = '1';
Then check if any errors are reported.

Does Developer Log reveal anything?

#9

Updated by Igor over 10 years ago

I have the same error when I want to make a copy of an extension template or a template in the list module

#10

Updated by Franz Koch over 10 years ago

same error on two different installations - one of them a clean 4.5.2 installation without any xclasses. Error occurs randomly on random records, sometimes even if I'm idle in the BE for about 15 minutes and only try to clear the cache then (error appears after reloading a BE page after clearing the cache). For the clear cache issue I have to relogin to fix it.

#11

Updated by Steffen Gebert over 10 years ago

Ho are you connected to the Internet? Is it possible that you got a new IP in the mean time, while being inactive?

#12

Updated by Franz Koch over 10 years ago

DSL with disconnect every 24 hours - so that's not the cause.

#13

Updated by Charles Coleman over 10 years ago

I am also getting this error seemingly randomly in the backend of this website:
http://www.rapidfyre.net

I haven't been able to pinpoint what is causing it but wanted to let you know that there are others having the issue as well. I will post more if/when I am able to debug...

#14

Updated by Steffen Kamper over 10 years ago

I had this issue today in t3editor in filelist - every second save failed due security token issue.

#15

Updated by Henjo Hoeksma over 10 years ago

I have also experienced this bug. Not been able to locate the problem exactly. Have not experienced it the last couple of days though...

#16

Updated by Christian Hernmarck over 10 years ago

I also had this message several times.
Either a full reload of the BE solved it - or a logout and login from/into the BE....

I don't use the kb_extensions, nor templavoila, nor phpmyadmin , nor quiyplorer...
Just wait a while and then try to edit something...

#17

Updated by Helmut Hummel over 10 years ago

Please do not abuse bug reports which are clearly related to one topic by reporting different issues. Open an additonal bug report instead.

The inital report was about kb_conttable which is not releated to TYPO3 core but is a problem in this extension.

I will close this one in favour of #25359 which explains what the current problem is in the core.

#18

Updated by Helmut Hummel over 10 years ago

This is an extension bug, not a core bug.

Also available in: Atom PDF