Bug #25326

FlexForms: saving of sections doesn't work (deletion fails, ordering is not saved)

Added by Rens Admiraal over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-03-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The ordering of elements in a flexform section is not saved on post. There are no javascript errors, and the actual order of the elements in the post request is rearranged correctly. But as soon as the element is saved the new ordering is lost.

Besides that deletion of elements doesn't work. The elements are removed correctly in the form, and the post request does contain a delete action, but after the saving the values are still available.

I've attached a sample extension in which the bug can be reproduced. The extension adds 2 flexform fields, the second field can be used to reproduce this bug.

(issue imported from #M17951)


Files

T3X_flexformerrors-0_1-z-201103151706.t3x (1.69 KB) T3X_flexformerrors-0_1-z-201103151706.t3x Administrator Admin, 2011-03-15 17:20
17950.diff (970 Bytes) 17950.diff Rens Admiraal, 2011-12-17 12:40

Related issues

Has duplicate TYPO3 Core - Bug #25325: FlexForms: Problem with click events for link_wizards in subelements of a sectionRejected2011-03-15

Actions
#1

Updated by Andreas Kiessling over 10 years ago

Hi,

remove index="0" from the numIndex and it should work
-> <numIndex type="array">

HTH,
Andreas

#2

Updated by Rens Admiraal over 10 years ago

Hi Andreas,

Thanks, it works :) Copy pasting ain't that good after all ;-)

Thanks!

#3

Updated by Sonja Schubert over 10 years ago

  • Target version deleted (0)

In my opinion the problem still exists, so the issue is still valid. After update to 4.5.2 deleting sections and sorting sections does not work any more with this flexform.

Does anyone have the same problem or a hint what is wrong with the flexform so it does not work anymore in 4.5.2?

<T3DataStructure>
    <meta type="array">
        <langChildren type="integer">1</langChildren>
        <langDisable type="integer">1</langDisable>
    </meta>
 <sheets>
  <sDEF>
   <ROOT>
    <TCEforms>
     <sheetTitle>....</sheetTitle>
    </TCEforms>
    <type>array</type>
     <el>
         <fields>
                <type>array</type>
                <section>1</section>
                <tx_templavoila>
                    <title>LLL:EXT:path/pi2/locallang.xml:flexform_header</title>
                </tx_templavoila>
                <el>
                    <item>
                        <type>array</type>
                        <tx_templavoila>
                            <title>LLL:EXT:path/pi2/locallang.xml:flexform_new_element</title>
                        </tx_templavoila>
                        <el>
                          <filelabel>
                           <TCEforms>
                            <label>LLL:EXT:path/pi2/locallang.xml:flexform.filelabel</label>
                            <config>
                             <type>input</type>
                             <size>30</size>
                             <max>256</max>
                             <eval>trim</eval>
                            </config>
                           </TCEforms>
                          </filelabel>
                          <file>
                           <TCEforms>
                            <label>LLL:EXT:path/pi2/locallang.xml:flexform.file</label>
                            <config>
                             <type>input</type>
                             <size>30</size>
                             <max>256</max>
                             <eval>trim</eval>
                             <softref>typolink</softref>
                             <wizards>
                                <_PADDING>2</_PADDING>
                                <link>
                                    <type>popup</type>
                                    <title>Link</title>
                                    <icon>link_popup.gif</icon>
                                    <script>browse_links.php?mode=wizard</script>
                                    <JSopenParams>height=300,width=500,status=0,menubar=0,scrollbars=1</JSopenParams>
                                </link>
                             </wizards>
                            </config>
                           </TCEforms>
                          </file>
                          </el>    
                    </item>
                </el>
            </fields>
     </el>
    </ROOT>
   </sDEF>
  </sheets>
</T3DataStructure>

Thank you for your help

Kind regards,

Sonja

#4

Updated by Sonja Schubert over 10 years ago

I found the problem. feeditadvanced uses a hook in tcemain to overwrite $_POST['_ACTION_FLEX_FORMdata'] nevertheless if it is empty or not. Will create an issue in their forge project

#5

Updated by Rens Admiraal almost 10 years ago

http://forge.typo3.org/issues/25325 is a duplicate of this issue, added the extra attachment of that issue to this one.

#6

Updated by Chris Müller over 9 years ago

I have the same problem with TYPO3 4.7beta3 in combination with the extension "Grid Elements". I am using a flexform with a section to give the editors the opportunity to create as many links as the need.

I can rearrange and delete an element but after saving of the flexform the original order and the deleted elements are still available.

My flexform configuration:

<?xml version="1.0" encoding="UTF-8"?>
<T3DataStructure>
    <meta>
        <langDisable>1</langDisable>
        <langChildren>0</langChildren>
    </meta>
    <sheets>
        <sDEF>
            <ROOT>
                <TCEforms>
                    <sheetTitle>General</sheetTitle>
                </TCEforms>
                <type>array</type>
                <el>
                    <linksContainer>
                        <title>Links</title>
                        <type>array</type>
                        <section>1</section>
                        <el>
                            <link>
                                <type>array</type>
                                <title>Link</title>
                                <el>
                                    <linkText>
                                        <TCEforms>
                                            <label>Link-Text</label>
                                            <config type="array">
                                                <type>input</type>
                                                <size>20</size>
                                                <eval>trim</eval>
                                            </config>
                                        </TCEforms>
                                    </linkText>
                                    <linkAddress>
                                        <TCEforms>
                                            <label>Link-Adresse</label>
                                            <config type="array">
                                                <type>input</type>
                                                <size>15</size>
                                                <max>256</max>
                                                <checkbox></checkbox>
                                                <eval>trim</eval>
                                                <wizards type="array">
                                                    <_PADDING type="integer">2</_PADDING>
                                                    <link type="array">
                                                        <type>popup</type>
                                                        <title>Link</title>
                                                        <icon>link_popup.gif</icon>
                                                        <script>browse_links.php?mode=wizard</script>
                                                        <JSopenParams>height=500,width=500,status=0,menubar=0,scrollbars=1</JSopenParams>
                                                    </link>
                                                </wizards>
                                            </config>
                                        </TCEforms>
                                    </linkAddress>
                                </el>
                            </link>
                        </el>
                    </linksContainer>
                </el>
            </ROOT>
        </sDEF>
    </sheets>
</T3DataStructure>

#7

Updated by Wouter Wolters almost 7 years ago

  • Description updated (diff)
  • Status changed from New to Needs Feedback
  • Is Regression set to No

Hi,

as this issue is very old. Is this feature missing in newer versions of TYPO3 CMS (6.2.9)?

#8

Updated by Rens Admiraal almost 7 years ago

wouter: I wouldn't know, maybe the other people that commented can still verify but I can't

#9

Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback which verifies this issue within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF