Bug #26690

Shortcut mode first subpage has current in label instead of selected

Added by Philipp Gampe over 11 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2011-05-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you go to page properties and change the page type to shortcut, you can select the shortcut mode first subpage of current page. However the current is wrong, because the page in shortcut target is used as reference page. You will get the first subpage of the target page instead of the first subpage of current page.

Only if target is empty, the current page is used as target.

Maybe the mode should only be called "first subpage".

The labels of the other shortcut modes are also effected.

Reporters: UG-NRW

#1

Updated by Oliver Hader about 11 years ago

  • Target version changed from 4.5.3 to 4.5.4
#2

Updated by Steffen Gebert about 11 years ago

Uh.. didn't even know that feature. Looks like we have to rename the labels.

#3

Updated by Philipp Gampe about 11 years ago

How to proceed here?

Do we still need to copy the labels first to fix this? Or can we just change them?
Or wait for new translate system? (If this gets backported to 4.5.)

#4

Updated by Mr. Hudson about 11 years ago

Patch set 1 of change I2d765665b1ee73a410e1b6fe8a619833b6850476 has been pushed to the review server.
It is available at http://review.typo3.org/2790

#5

Updated by Mr. Hudson about 11 years ago

Patch set 2 of change I2d765665b1ee73a410e1b6fe8a619833b6850476 has been pushed to the review server.
It is available at http://review.typo3.org/2790

#7

Updated by Oliver Hader about 11 years ago

  • Target version changed from 4.5.4 to 4.5.6
#8

Updated by Andreas Wolf almost 11 years ago

  • Status changed from New to Accepted

Looks like we need a new patch here - the XLIFF transition took place, so the LLXML patch became invalid.

Oh, and btw., what's the current policy for changing existing LL labels? I thought no changes were allowed, but I guess this goes as a clarification, so it should be ok.

#9

Updated by Mr. Hudson almost 11 years ago

Patch set 3 of change I2d765665b1ee73a410e1b6fe8a619833b6850476 has been pushed to the review server.
It is available at http://review.typo3.org/2790

#10

Updated by Chris topher almost 11 years ago

  • Target version changed from 4.5.6 to 4.5.8
#11

Updated by Mr. Hudson almost 11 years ago

  • Status changed from Accepted to Under Review

Patch set 4 of change I2d765665b1ee73a410e1b6fe8a619833b6850476 has been pushed to the review server.
It is available at http://review.typo3.org/2790

#12

Updated by Gerrit Code Review over 10 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/2790

#13

Updated by Stefan Neufeind over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF