Bug #28967

JSON arrays in AJAX response sometimes incomplete

Added by Christian Lerrahn over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-08-14
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've posted this on the dev list before and cannot get to the bottom of it. The problem seems to erratically go away and come back again.

Sometimes, I get connection problems in the workspace module when I try reading the changes for a page. I've investigated this from the server side and found that incomplete JSON arrays are being sent. While the content length in the header seems correct, the content is truncated about half way.

At first it seemed this only happened when the server was under heavy load. However, testing that longer term, did not confirm that suspicion. Doubling the memory available to PHP also did not fix the problem.

No Apache, system, MySQL or PHP logs show any errors in conjunction with this phenomenon. The timeouts are extremely long (15min), all resource limits should be more than plenty. I've also had this problem on two different servers with the same site. One ran Gentoo x86 Linux and the other one Debian Squeeze.

I have been unable to work out a pattern when this issue arises and when it doesn't. It also often does not affect all pages at once but often only applies to a seemingly arbitrary subset of pages.

I'm happy to contribute more findings if anyone has hints what else to try.

truncated-response.txt View (4.1 KB) Christian Lerrahn, 2011-08-23 07:56


Related issues

Related to TYPO3 Core - Bug #28687: pagetree broken due to js exception Closed 2011-08-02
Related to TYPO3 Core - Bug #29094: Pagetree Filter - Sometimes subpages can't be opened Closed 2011-08-18

History

#1 Updated by Tolleiv Nietsch over 8 years ago

  • Status changed from New to Needs Feedback

Haven't seen this yet - are you able to reproduce it with a normal introduction package? how?

#2 Updated by Christian Lerrahn over 8 years ago

I'll have a crack at reproducing it on a test system with an introduction package. However, the error is very erratic, so I'm not too confident I'll be able to.

Another clue is that this seems to affect the same pages over and over. Sometimes, everything works for all but one page. Also, it never seems to be a problem to view changes in the LIVE workspace via the Workspace module.

Maybe it helps to post a typical truncated response. I've attached one as I logged it on the server.

I noticed that there is a time out of 15s in the Keep-Alive header line. Can that be changed? Maybe that would help already...

#3 Updated by Christian Lerrahn over 8 years ago

Another clue I just found...

Copying the whole page in draft means that the problem does not affect the copy. I can publish the copy without any problems.

Furthermore, I have the suspicion that these pages never get highlighted even when they have been modified in the draft workspace.

#4 Updated by Tolleiv Nietsch about 8 years ago

Sorry it's hard to work on this without clear description. The truncated response can also happen due to Apache or Proxy setup.

Please try to figure out how to reproduce it within a "normal" introduction package installation.

#5 Updated by Michael Stucki over 6 years ago

  • Category changed from Bugs to Workspaces

#6 Updated by Michael Stucki over 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#7 Updated by Alexander Opitz about 6 years ago

  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (6.1.7)?

#8 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF