Bug #29094

Pagetree Filter - Sometimes subpages can't be opened

Added by Florian Bachmann over 9 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Start date:
2011-08-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Step1: I enter a searchterm in the pagetree filter, The resulting page is opened
Step2: I open each of the subpages with the arrow-icon
Step3: Some of the subpages work in opening. Some of the subpages can't be opened, althogh subpages are available

See attached Screenshots, they explain the problem best

I can't see any reasonable connection wich subpages are openable and which are not


Files

bugpagetree.png (76.7 KB) bugpagetree.png Florian Bachmann, 2011-08-18 18:47
pagetree_update_bug.png (69 KB) pagetree_update_bug.png Florian Bachmann, 2011-08-22 17:35
pages.sql_1_.zip (680 KB) pages.sql_1_.zip Florian Bachmann, 2011-08-22 17:35

Related issues

Related to TYPO3 Core - Bug #28687: pagetree broken due to js exceptionClosedSteffen Ritter2011-08-02

Actions
Related to TYPO3 Core - Bug #28967: JSON arrays in AJAX response sometimes incompleteClosed2011-08-14

Actions
Related to TYPO3 Core - Bug #88259: Filtered pagetree should display child pagesClosed2019-05-03

Actions
#1

Updated by Florian Bachmann over 9 years ago

I don't see a relation to the other two bugs.
Are you sure this is a related problem?
I don't see any warning, and the pagetree stays fully operable, except the stated bug.

Workspaces aren't enabled on that site

#2

Updated by Florian Bachmann over 9 years ago

To make it easy, to reproduce the bug, I made a script-generated similar page-tree.
It contains of a Tree, leading to a zip-code, with stores appended to a zip.

To reproduce the bug
- install a completely fresh 4.5
- only import the pages-table-dump
- enter e.g. "807" to the filter-input field
- open nodes up to "80792" and try to open store8333
=> No child nodes are visible in the tree, although there should be

--
Please undo the related connection

#3

Updated by Ingmar Schlecht over 9 years ago

  • Status changed from New to Needs Feedback

Hmm, Florian Kuss, would it be possible for you to try to debug the issue?

The classes responsible for the tree display are located in t3lib/tree/.

#4

Updated by Susanne Moog over 9 years ago

Could you count how many pages are shown when using the filter? I'm wildly guessing that there is a limit somewhere.

#5

Updated by Andreas Wolf about 9 years ago

  • Category set to Pagetree
  • Complexity set to medium
#6

Updated by Stefan Galinski almost 9 years ago

  • Status changed from Needs Feedback to New
#7

Updated by Stefan Galinski over 8 years ago

  • Subject changed from Bug pagetree filter to Pagetree Filter - Sometimes subpages can't be opened
#8

Updated by Mathias Schreiber almost 6 years ago

  • Target version set to 7.4 (Backend)
  • Is Regression set to No
#9

Updated by Susanne Moog over 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#10

Updated by Benni Mack about 5 years ago

  • Target version changed from 7.5 to 8 LTS
#11

Updated by Benni Mack over 3 years ago

  • Target version changed from 8 LTS to Candidate for patchlevel
#12

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from New to Needs Feedback

Hi. Could you tell us if this issue still occurs in TYPO3 v.9? How could we reproduce it? Thank you!

#13

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Needs Feedback to Closed

I think I can safely close this one for now- there has been no answer 6 (!) years ago and no significant advancement...

If you think that this is the wrong decision or experience the issue again please reopen it or open a new issue with a reference to this one. Thank you.

#14

Updated by Daniel Siepmann 11 months ago

  • Related to Bug #88259: Filtered pagetree should display child pages added

Also available in: Atom PDF