Project

General

Profile

Actions

Bug #28974

closed

Sorting of content elements fails in workspaces

Added by Hendrik Becker almost 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2011-08-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This behaviour occurs in TYPO3 4.4.9 as well.

Reproduction steps:
1. Create a test workspace
2. Live space: Create a page
3. Live space: Create two content elements within the new page
e.g.:
- Test1
- Test2

4. Change to test workspace
5. Test workspace: Move down the first element (Test1) - this works
e.g.:
- Test2
- Test1

6. Test workspace: Move down the second element (Test2) - this fails, the order does not change

Just guessing why:
The bug might be within the method t3lib_TCEmain::getSortNumber. It seems like the sorting relies on the sorting value from the live versions. That would explain why moving around a single item works fine, but when moving a 2nd item it fails.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #31663: Moving pages (and page content) in the Workspace does not workClosedStefan Neufeind2011-11-08

Actions
Actions #1

Updated by Tolleiv Nietsch almost 13 years ago

  • Status changed from New to Accepted
Actions #2

Updated by Stefan Neufeind over 12 years ago

  • Status changed from Accepted to Needs Feedback

Could you please see if I'm right this is a "duplicate" of the issue described in 31663? There is a patch currently under review. It would be great if you could try that out (only a few lines actually) and see if that solves the problem for you.

Actions #3

Updated by Oliver Hader over 12 years ago

  • Status changed from Needs Feedback to Resolved
  • Target version set to 4.5.8

Handled in issue #31663

Actions #4

Updated by Michael Stucki over 10 years ago

  • Category changed from Bugs to Workspaces
Actions #5

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF