Project

General

Profile

Actions

Bug #29019

closed

getSingleField_typeFlex doesn' respect TSconfig settings

Added by Jo Hasenau almost 13 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2011-08-16
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The Handler for Flexforms getSingleField_typeFlex doesn't respect the TSconfig settings for flexforms that have been introduced with TYPO3 4.5.
This is due to the fact that it calls $flexFormHelper->modifyFlexFormDS with the wrong configuration array.

In line 2488 it should be

$dataStructArray = $flexFormHelper->modifyFlexFormDS($dataStructArray, $table, $field, $row, $PA['fieldConf']);

instead of

$dataStructArray = $flexFormHelper->modifyFlexFormDS($dataStructArray, $table, $field, $row, $PA['fieldConf']['config']);

to get the same behaviour as in class.t3lib_transferdata.php => renderRecord_flexProc, which does respect the settings perfectly.

Actions #1

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change I73bb1739d9b85320f00f4a228ade898d41a5df9c has been pushed to the review server.
It is available at http://review.typo3.org/4377

Actions #2

Updated by Mr. Hudson almost 13 years ago

Patch set 2 of change I73bb1739d9b85320f00f4a228ade898d41a5df9c has been pushed to the review server.
It is available at http://review.typo3.org/4377

Actions #3

Updated by Susanne Moog almost 13 years ago

  • Status changed from New to Under Review
Actions #4

Updated by Andreas Wolf almost 13 years ago

As said on Gerrit, I can't reproduce the bug behind this. The following configuration will override the sheet title and add a new item to the first select list in the tt_news plugin:

TCEFORM.tt_content.pi_flexform.9 {
  sDEF {
    sheetTitle = New sheet title

    ascDesc = desc
    what_to_display.addItems {
      new_key = New label
    }
  }
}
Actions #5

Updated by Jo Hasenau almost 13 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF