Bug #29211

Height of RTE editing area sometimes null in Safari 5.1

Added by Peter Kraume about 9 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2011-08-24
Due date:
% Done:

100%

TYPO3 Version:
4.4
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Safari 5.1 still has an issue with the RTE. I've installed TYPO3 4.4.10. But I assume that this issue affects TYPO3 4.5.5 and 4.3.13 as well.

You can edit a content element once. But when you save it and open it again, the RTE window shows the buttons but no content (see screenshot).

I've deleted all files in typo3temp/rtehtmlarea.

This issue relates to #28360

safari_5.1.png View (25.5 KB) Peter Kraume, 2011-08-24 11:54

Associated revisions

Revision 2d430f59 (diff)
Added by Stanislas Rolland about 9 years ago

[BUGFIX] Height of RTE editing area sometimes null in Safari 5.1

Solution: Use same height setting method as for Chrome 7+.

Change-Id: I26e1777b8ec5d616d623699b409070e8a3629022
Resolves: #29211
Releases: 4.4, 4.5, 4.6
Reviewed-on: http://review.typo3.org/4736
Reviewed-by: Peter Kraume
Tested-by: Peter Kraume
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Ingmar Schlecht about 9 years ago

  • Assignee set to Stanislas Rolland

#2 Updated by Stanislas Rolland about 9 years ago

I am unable to reproduce this with Safari 5.1 on Windows using TYPO3 4.5.6-dev or TYPO3 4.4.11-dev.

#3 Updated by Stanislas Rolland about 9 years ago

Please clear the RTE cache using the TYPO3 clear cache menu and clear the browser cache.

#4 Updated by Jan Bartels about 9 years ago

I can confirm the behavior described by Peter. I've cleared the T3-cache and the browser cache before. Safari 5.1 on Windows, T3 4.4.10

It seems to work, if I clear the browser cache every time (!) just right before opening an RTE.

#5 Updated by Stanislas Rolland about 9 years ago

Jan Bartels wrote:

I can confirm the behavior described by Peter. I've cleared the T3-cache and the browser cache before. Safari 5.1 on Windows, T3 4.4.10

1. Did you clear the RTE cache using the BE Clear cache menu?

2. If you toggle to text mode, can you see that the content is correct?

#6 Updated by Jan Bartels about 9 years ago

Stanislas Rolland wrote:

1. Did you clear the RTE cache using the BE Clear cache menu?

Yes, that was the first action before testing.

2. If you toggle to text mode, can you see that the content is correct?

Yes. After toggling to text mode, the content is correct.

#7 Updated by Stanislas Rolland about 9 years ago

OK. I was finally able to reproduce this issue. Correct me if I am wrong:

1. This issue does not arise in TYPO3 4.5.

2. The issue does not arise when editing an existing content element.

3. The issue arises in TYPO3 4.4 when creating a new content element and hitting the save button. Then the height of the editing area (initially in a hidden tab) is zero.

#8 Updated by Stanislas Rolland about 9 years ago

  • Subject changed from RTE works only once in Safari 5.1 to Height of RTE editing area sometimes null in Safari 5.1

#9 Updated by Mr. Hudson about 9 years ago

Patch set 1 of change I26e1777b8ec5d616d623699b409070e8a3629022 has been pushed to the review server.
It is available at http://review.typo3.org/4736

#10 Updated by Stanislas Rolland about 9 years ago

Please test this patch: http://review.typo3.org/4736

#11 Updated by Stanislas Rolland about 9 years ago

  • Status changed from New to Under Review

#12 Updated by Stanislas Rolland about 9 years ago

I was unable to reproduce this issue with TYPO3 4.5. Perhaps due to different version of ExtJS...

#13 Updated by Michael Kasten about 9 years ago

I try these changes today, but it will not resolved the Problem:
I cleared the BE an the Browser Cache, tested under
TYPO3 4.4.10 / Safari 5.1 / Windows 7

#14 Updated by Jan Bartels about 9 years ago

Stanislas Rolland wrote:

OK. I was finally able to reproduce this issue. Correct me if I am wrong:

1. This issue does not arise in TYPO3 4.5.

I don't have a T3 4.5 to test on.

2. The issue does not arise when editing an existing content element.

NACK. The issue does arise on existing CEs also.

3. The issue arises in TYPO3 4.4 when creating a new content element and hitting the save button. Then the height of the editing area (initially in a hidden tab) is zero.

Saving new CEs work also (after the patch; haven't tried before).

Please test this patch: http://review.typo3.org/4736

This patch works for me. I will get in contact with our editors to confirm the solution for other environments.

#15 Updated by Peter Kraume about 9 years ago

Works fine for me. Tested with TYPO3 4.4.10, Mac OS X 10.7.1 and Safari 5.1

#16 Updated by Jan Bartels about 9 years ago

Jan Bartels wrote:

Stanislas Rolland wrote:

Please test this patch: http://review.typo3.org/4736

This patch works for me. I will get in contact with our editors to confirm the solution for other environments.

Our Safari users are happy with this patch. Thanks to Stanislas.

#17 Updated by Stanislas Rolland about 9 years ago

Michael Kasten wrote:

I try these changes today, but it will not resolved the Problem:
I cleared the BE an the Browser Cache, tested under
TYPO3 4.4.10 / Safari 5.1 / Windows 7

Did you clear the RTE cache using the BE Clear cache menu?

I cannot reproduce this issue after applying the patch. Can you provide me access to a site where the problem still arises?

Stanislas

#18 Updated by Michael Kasten about 9 years ago

Stanislas Rolland wrote:

Michael Kasten wrote:

I try these changes today, but it will not resolved the Problem:
I cleared the BE an the Browser Cache, tested under
TYPO3 4.4.10 / Safari 5.1 / Windows 7

Did you clear the RTE cache using the BE Clear cache menu?

I cannot reproduce this issue after applying the patch. Can you provide me access to a site where the problem still arises?

Stanislas

I made the changes at the htmlarea.js file local and update them at the server, but....

i have better have pay more attention at the file permission by the server files :)

Thank you Stanislas!

.. so i will take the facepalm :)

#19 Updated by Stanislas Rolland about 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#20 Updated by Patricia Schneider about 9 years ago

I tried the patch and it is not working for me. (Typo3 4.5.3/ Safari 5.1 / Windows 7). I cleared the BE and Browser Cache and the files have the right permission on the server after the changes, but the problem is still there...

#21 Updated by Peter Kraume about 9 years ago

Patricia Schneider wrote:

I tried the patch and it is not working for me. (Typo3 4.5.3/ Safari 5.1 / Windows 7). I cleared the BE and Browser Cache and the files have the right permission on the server after the changes, but the problem is still there...

You should update your TYPO3 to 4.5.5 first and then apply the patch.

#22 Updated by Patricia Schneider about 9 years ago

Thank you :)

You should update your TYPO3 to 4.5.5 first and then apply the patch.

after the Update everything worked perfect.

#23 Updated by Ernesto Baschny over 7 years ago

  • Target version deleted (1341)

#24 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF