Bug #29367

"TCEMAIN.clearCacheCmd = all" and Cachingframework with FileBackend

Added by Thomas Dudzak almost 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2011-08-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Hello,

I'm using TYPO3 4.5.5 and there seems to be a bug in the CachingFramework:

While using the Cachingframework with FileBackend and the typoscript condition tcemain.clearCacheCmd= all, an error message is passed: "The temporary cache file "[snip]/typo3temp/cache/clear_hash/[snip]" could not be written.". The caching framework seems to try to change a cached hash file, that is already cleared.

When changing the typoscript condition to "TCEMAIN.clearCacheCmd = pages" it works in Frontend, but can't clear - of course - cache hashes...

A similar cache problem was reported for memcache in 2008 (http://bugs.typo3.org/view.php?id=9645)


Related issues

Related to TYPO3 Core - Bug #39122: Invalid chmod by default for folder typo3temp/Cache/Data/t3lib_l10n/Closed2012-07-20

Actions

Also available in: Atom PDF