Bug #39122

Invalid chmod by default for folder typo3temp/Cache/Data/t3lib_l10n/

Added by Alban Cousinie over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-07-20
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

My Typo3 log is filled up with this kind of entries :

13:20:01 _cli_scheduler@LIVE [5] [5_0] Core: Error handler (BE): PHP Warning: file_put_contents(/home/aubagne.fr/httpdocs/typo3temp/Cache/Data/t3lib_l10n/50093ee242a9c.temp): failed to open stream: Permission denied in /home/aubagne.fr/typo3_src-4.7.1/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 275
13:15:01 . . . Core: Error handler (BE): PHP Warning: file_put_contents(/home/aubagne.fr/httpdocs/typo3temp/Cache/Data/t3lib_l10n/50093db5a9afe.temp): failed to open stream: Permission denied in /home/aubagne.fr/typo3_src-4.7.1/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 275
13:10:01 . . . Core: Error handler (BE): PHP Warning: file_put_contents(/home/aubagne.fr/httpdocs/typo3temp/Cache/Data/t3lib_l10n/50093c89b75a0.temp): failed to open stream: Permission denied in /home/aubagne.fr/typo3_src-4.7.1/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 275
13:05:02 . . . Core: Error handler (BE): PHP Warning: file_put_contents(/home/aubagne.fr/httpdocs/typo3temp/Cache/Data/t3lib_l10n/50093b5e417ad.temp): failed to open stream: Permission denied in /home/aubagne.fr/typo3_src-4.7.1/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 275

This is due to the fact the folder typo3temp/Cache/Data/t3lib_l10n/ which is automatically created by typo3 has a default permission of drwxr-xr-x instead of drwxrwxr-x (like its parent directories).


Related issues

Related to TYPO3 Core - Bug #29367: "TCEMAIN.clearCacheCmd = all" and Cachingframework with FileBackend Closed 2011-08-30
Related to TYPO3 Core - Bug #46205: Cache file could not be written on concurrent actions Closed 2013-03-12
Related to TYPO3 Core - Bug #47912: Improvment of LanguageCacheClearer Closed 2013-05-04

History

#1 Updated by Ernesto Baschny over 7 years ago

  • Status changed from New to Needs Feedback

Could you please specify which version of TYPO3 you are using?

What is your settings (in Install Tool > All Configuration) of "folderCreateMask" and "fileCreateMask"?

What's the user + group of the directories? If TYPO3 has created the directories, its strang if it cannot write inside it (as the user would be the same). Are you sure that the directories were created by TYPO3?

#2 Updated by Ernesto Baschny over 7 years ago

Maybe related to this: #32261? This was resolved in 4.6.5 and 4.7.0.

#3 Updated by Sebastian During over 7 years ago

The same problem.

Typo3 4.7.2

After chown to the right user, a few min. the rights are back to root

/typo3temp/Cache/Data
drwxrwxrwx 3 www-data www-data 4096 Jul 27 20:55 .
drwxrwxrwx 4 www-data www-data 4096 Jul 27 19:37 ..
drwxr-xr-x 2 root root 4096 Jul 27 20:55 t3lib_l10n

Both Option are not set.

in the Version 4.7.1 was all ok. I will go back.

#4 Updated by Sebastian During over 7 years ago

Oops, an error occurred!

The temporary cache file "/var/www/www.svbalingen.de/htdocs/typo3temp/Cache/Data/t3lib_l10n/5012e954598c5.temp" could not be written.

More information regarding this error might be available online.

Exceptionv4/1204026251

#5 Updated by Sebastian During over 7 years ago

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1204026251: The temporary cache file "/var/www/www.svbalingen.de/htdocs/typo3temp/Cache/Data/t3lib_l10n/5012e954598c5.temp" could not be written. | t3lib_cache_Exception thrown in file /opt/typo3_src/typo3_src-4.7.2/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php in line 279. Requested URL: http://direkt.svbalingen.de/nc/home.html

#6 Updated by Sebastian During over 7 years ago

After a downgrade the same problem:

$TYPO3_CONF_VARS['BE']['createGroup'] = 'www-data';
has helped.

/typo3temp/Cache/Data
drwxr-xr-x 3 www-data www-data 4096 Jul 27 21:45 .
drwxr-xr-x 4 www-data www-data 4096 Jul 27 21:45 ..
drwxr-xr-x 2 www-data www-data 4096 Jul 27 21:46 t3lib_l10n

#7 Updated by Alban Cousinie over 7 years ago

Hello,

I have set :
[BE][fileCreateMask] = 0775
[BE][folderCreateMask] = 0775
$TYPO3_CONF_VARS['BE']['createGroup'] = 'www-data';

And I still have the error :
10:10:01 _cli_scheduler@LIVE [5] [5_0] Core: Error handler (BE): PHP Warning: file_put_contents(/home/mysite.fr/httpdocs/typo3temp/Cache/Data/t3lib_l10n/5016415a3b4c8.temp): failed to open stream: Permission denied in /home/mysite.fr/typo3_src-4.7.2/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 275

Notice the error only happens with the _cli_scheduler user executed every five minutes from the scheduler task. The only task I have configured in the scheduler is "Direct Mail: Mailing Queue (direct_mail)".

This error is weird because now all the rights should be fine :

~/httpdocs/typo3temp/Cache/Data$ ls -lah t3lib_l10n/
total 1,4M
drwxrwxr-x 2 www-data www-data 4,0K 30 juil. 10:24 .
drwxrwxrwx 3 mysite.fr www-data 4,0K 30 juil. 10:07 ..
-rwxrwxr-x 1 www-data www-data 1,5K 30 juil. 10:24 01e406b7cb4721e5ff7a9b978b0296eb
-rwxrwxr-x 1 www-data www-data 9,0K 30 juil. 10:24 05fe4b52e37488179a7a054d8dd5be0c
-rwxrwxr-x 1 www-data www-data 1,1K 30 juil. 10:08 07b8eed42a4f91ff4f4a8d44bb6f5623
-rwxrwxr-x 1 www-data www-data 108K 30 juil. 10:24 08749ef75bfba407ae345e7a42902c7e
...

#8 Updated by Marco over 7 years ago

Sebastian During wrote:

The same problem.

Typo3 4.7.2

After chown to the right user, a few min. the rights are back to root

/typo3temp/Cache/Data
drwxrwxrwx 3 www-data www-data 4096 Jul 27 20:55 .
drwxrwxrwx 4 www-data www-data 4096 Jul 27 19:37 ..
drwxr-xr-x 2 root root 4096 Jul 27 20:55 t3lib_l10n

Both Option are not set.

in the Version 4.7.1 was all ok. I will go back.

Hello. I have the same problem.
I have Typo3 version 4.7.1 and PHP 5.3.6, Plesk 8.6 on Centos 5.7.
After chown to the right user, probabily when accessing to the backend,
the rights (i.e. the owner) on directory t3lib_l10n, changes and
T3 gives an error message it cannot write temporary files.
May be you have already fixed this problem, can you confirm?
Is any fix available?

#9 Updated by Vladimir Kubak over 7 years ago

Not sure if it is the same problem. Our syslog is flooded by:
Core: Error handler (BE): PHP Warning: rename(........ typo3temp/Cache/Data/t3lib_l10n/507b4456cb0be.temp,...... typo3temp/Cache/Data/t3lib_l10n/3643f12306800ae26ecdd5e7e309e2e1): No such file or directory in ......... typo3_src-4.7.4/t3lib/cache/backend/class.t3lib_cache_backend_filebackend.php line 288

#10 Updated by Jonas Götze over 7 years ago

I have the same error:

The temporary cache file "[...]/typo3temp/Cache/Data/t3lib_l10n/508e588e0487f.temp" could not be written.

The folder belongs to root then - after chown everything works fine. But after some time the folder is empty and again belongs to root -> Error.

#11 Updated by Thorsten Kahler over 7 years ago

You have to coordinate web server user and CLI user: if you can't use the same user for both they should be at least member of a common group. This group has to be set in $TYPO3_CONF_VARS['BE']['createGroup'] then.

An alternative can be to instrumentalize filesystem ACLs or set permissions of created files and folders to be globally writable (see folderCreateMask and fileCreateMask already mentioned above). For security reasons I strongly advise not to use the latter workaround!

#12 Updated by Alexander Opitz almost 7 years ago

The problem is a race condition. One thread tries to save a cache file while the other removed the path to clear the cache.

This was fixed by #46205 with its follow up #47912

#13 Updated by Alexander Opitz almost 7 years ago

Please try the patches in the given issues and report if it is resolved.

#14 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

No feedback for over 90 days.

Also available in: Atom PDF