Bug #31188

rsaauth only checks if key generation works on Windows

Added by Helmut Hummel over 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Authentication
Target version:
Start date:
2011-10-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The php backend in rsaauth checks if it would work correctly by testing if key generation would work. But this is only checked on Windows platforms.
Since there also could be nix platforms with a wrong OpenSSL configuration, we should remove this limitation and check in any case.


Related issues

Related to TYPO3 Core - Bug #49273: Problems using rsaauth with openssl on WindowsClosed2013-06-20

Actions
Precedes TYPO3 Core - Bug #33165: rsaauth PHP backend calls key generation on every page request.Closed2012-01-13

Actions
#1

Updated by Mr. Hudson over 9 years ago

  • Status changed from New to Under Review

Patch set 1 of change Id075445f1fbf9bd37ca44525257892052a94c6e5 has been pushed to the review server.
It is available at http://review.typo3.org/6192

#2

Updated by Steffen Gebert over 9 years ago

  • Category set to Authentication
#3

Updated by Steffen Gebert over 9 years ago

Only one review by testing missing!

#4

Updated by Anonymous over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Steffen Gebert over 9 years ago

Could you please have a look at #33165 - it looks like the calls to isAvailable() during every request isn't very economic..

#6

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF