Bug #31761

Live search does not implement search properties

Added by Francois Suter almost 11 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Category:
Backend User Interface
Target version:
Start date:
2011-11-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

With #26829 new TCA properties were added to improve the efficiency of the backend search. However these properties were not applied to the live search, hence both searches produce different results, which is not the expected behavior.

Furthermore the live search must load the full TCA of any table it searches in (as necessary) in order to be able to find anything at all for tables for which the full TCA is not yet loaded (see #31760).


Related issues

Related to TYPO3 Core - Task #26829: Improve Backend searchClosedDmitry Dulepov2011-05-16

Actions
Related to TYPO3 Core - Bug #31760: Live search does not find all tablesClosedFrancois Suter2011-11-11

Actions
Related to TYPO3 Core - Bug #33700: Invalid behavior of search for integer in Backend searchClosed2012-02-06

Actions
#1

Updated by Xavier Perseguers over 10 years ago

  • Target version changed from 4.6.1 to 4.6.2
#2

Updated by Stefan Neufeind over 10 years ago

I think this is related to what I experience with 4.6.3 (and tt_news 3.1.0). We added

$TCA['tt_news']['ctrl']['searchFields'] = 'title';

to typo3conf/extTables.php and from there on it was possible to search inside the titles of a news-entry using the search-functionality below a page. (Using the introduction-package you may search for "t3uxw".)
However the live search/quick search still doesn't contain those tt_news-entries.

Funny enough: When clicking the "Show all"-button below the live-search you get them ... since then the normal search-functionality is used.

#3

Updated by Francois Suter over 10 years ago

Yes exactly.

I still mean to work on this some day, but it's not my top priority for now. Of course anyone should feel free to pick it up ;-)

#4

Updated by Francois Suter over 10 years ago

  • Target version changed from 4.6.2 to 4.6.5
#5

Updated by Francois Suter over 10 years ago

  • Complexity changed from easy to medium
#6

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8750

#7

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8750

#8

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8882

#9

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF