Bug #32422

Encoding error in TCEforms inline JavaScript

Added by Lukas Rüegg about 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2011-12-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The fix introduced for issue #29067 has broken the linkbrowser popup for new elements in sections. The FCE has to be saved in order for the link to work.
See http://screencast-o-matic.com/watch/cXlQ2NvqJ


Files

Linkbrowser.pdf (33 KB) Linkbrowser.pdf Lukas Rüegg, 2011-12-09 19:37
class.t3lib_tceforms.php.patch (1.12 KB) class.t3lib_tceforms.php.patch Manuel Stofer, 2012-01-31 17:37
T3X_demo_bug_32422.t3x (1.51 KB) T3X_demo_bug_32422.t3x Manuel Stofer, 2012-02-01 14:11

Related issues

Related to TYPO3 Core - Bug #29067: Encoding UTF-8 in unescape functionClosed2011-08-18

Actions
Related to TYPO3 Core - Bug #34330: Encoding error in flexform sections if backend is not UTF-8Closed2012-02-27

Actions
Has duplicate TYPO3 Core - Bug #32238: Bugfix #28952 breaks sections in flexformsClosedTolleiv Nietsch2011-12-01

Actions
#1

Updated by Steffen Gebert about 9 years ago

  • Priority changed from Must have to Should have

Could you explain it a bit? I don't get your point. Please include all your information here, too. Is this only related to Templavoila?

#2

Updated by Lukas Rüegg about 9 years ago

The change made to the TCE forms class from issue #29067 breaks links which open the link browser.
As described this only happens in FCEs which have sections. For example, I have an FCE where i can add elements in a section and there's a field with a link to the link browser in each element of the section. Whenever I add a new element to the section the link to the linkbrowser will not work until I save the FCE.
Although this only happens in TemplaVoila FCEs with sections it is related to TCE Forms and it can be fixed by reverting issue #29067

#3

Updated by Manuel Stofer almost 9 years ago

using json_encode instead of unescape, decodeURIComponent and rawurlencode solves the problem

@see patch

#4

Updated by Steffen Gebert almost 9 years ago

Thanks, Manuel! Could you push this to our review system Gerrit, please? http://wiki.typo3.org/Contribution_Walkthrough

Thanks for your contribution!

#5

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8790

#6

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8792

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8790

#8

Updated by Manuel Stofer almost 9 years ago

A small demo of the problem is attached. I hope it helps to review the patch.

#9

Updated by Steffen Gebert almost 9 years ago

  • Assignee set to Steffen Gebert
  • Target version set to 4.5.12

Great, thanks a lot! I appreciate that you made the review so easy by creating the extension!

#10

Updated by Steffen Gebert almost 9 years ago

  • Subject changed from Fix for bug #29067 introduces new bug to Encoding error in TCEforms inline JavaScript
#11

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8831

#12

Updated by Steffen Gebert almost 9 years ago

  • Status changed from Under Review to Resolved
#13

Updated by Helmut Hummel almost 9 years ago

This solution still does not work for forceCharset anything different to utf-8. json_encode fails when specail characters are present.
The php manual clearly states that json_encode only works for utf-8: http://www.php.net/manual/en/function.json-encode.php

#14

Updated by Steffen Gebert almost 9 years ago

Aren't we utf8-only in 4.7?

#15

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF