Bug #32967

Bug #46389: Faulty Workspace Placeholders

Backend workspace copy/cut paste column content fails on publish

Added by Jakob Berlin almost 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-01-04
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

1. Go to draft workspace
2. Cut content from normal column
3. Paste content into right column
4. Publish changes

-> Copied content appears in normal column again.

Any idea where this happens? I'm maybe able to fix it if I know where this happens...

1.png View - Step 1 (53.7 KB) Jakob Berlin, 2012-01-04 15:41

3.png View - Step 2 (54.6 KB) Jakob Berlin, 2012-01-04 15:41

wrongtextelementcolumns.JPG View - DB behavoir in Typo3 4.5.5 (78.6 KB) Jakob Berlin, 2012-01-04 15:41

bug_32967.diff View - Changes in typo3_src-4.5.10/typo3/sysext/version/class.tx_version_tcemain.php which fixes bug for me (1.57 KB) Jakob Berlin, 2012-01-04 17:54


Related issues

Related to TYPO3 Core - Bug #44470: Content elements in wrong column in page module Closed 2013-01-13
Related to TYPO3 Core - Task #56994: Introduce shadowColumnsForMovePlaceholders property Closed 2014-03-17
Precedes TYPO3 Core - Bug #39983: Change colPos of content element in draft workspace Closed 2012-08-20

History

#1 Updated by Jakob Berlin almost 8 years ago

In Typo3 4.5.10 the screenshot of DB behavoir is not reproduceable for me. It seems that something changed here. Now a row with MOVE-TO PLACEHOLDER and setup "t3ver_move_id" appears before publish and disappears after publish. In the "new" row the colpos value is right but not seems to be used...

#2 Updated by Jakob Berlin almost 8 years ago

After hours of researching through the core I found the (a?) location where I can fix it. See diff file. Is this the right/best/only location? Someone with more Typo3-Core-Skill should check this.

If fine I can commit this to git repo.

#3 Updated by Simon Schaufelberger almost 8 years ago

If fine I can commit this to git repo.

you can ALWAYS push to gerrit. code review will be done there and not HERE in forge so go ahead and push!
Then it is also easier to review since you can just checkout your commit into your own local repo.

#4 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7691

#5 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7691

#6 Updated by Gerrit Code Review almost 8 years ago

removed (created new change by accident)

#7 Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7691

#8 Updated by Ernesto Baschny over 7 years ago

  • Target version changed from 4.5.11 to 4.5.12

#9 Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7691

#10 Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7691

#11 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18107

#12 Updated by Oliver Hader over 6 years ago

  • Parent task set to #46389

#13 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18107

#14 Updated by Gerrit Code Review about 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18107

#15 Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18107

#16 Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18107

#17 Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#18 Updated by Gerrit Code Review almost 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#19 Updated by Gerrit Code Review almost 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#20 Updated by Gerrit Code Review almost 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#21 Updated by Gerrit Code Review over 5 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#22 Updated by Gerrit Code Review over 5 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#23 Updated by Gerrit Code Review over 5 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/18107

#24 Updated by Wouter Wolters almost 5 years ago

  • Status changed from Under Review to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

#25 Updated by Riccardo De Contardi over 4 years ago

  • Status changed from Needs Feedback to Closed

I tried with both 6.2.12 and 7 (latest master) and I was not able to reproduce the bug, so I close this for now.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Please note that I had to use this https://review.typo3.org/#/c/39430/ to make WS usable on 7

Also available in: Atom PDF