Project

General

Profile

Actions

Bug #39983

closed

Change colPos of content element in draft workspace

Added by Richard Schaufler almost 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
Start date:
2012-08-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When i change the column of an element within a draft workspace, the content element doesn't get displayed in the new assigned column (backend and frontend). Publishing of the change works though. Tested in TYPO3 4.5.17 and 4.7.3.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #44470: Content elements in wrong column in page moduleClosedOliver Hader2013-01-13

Actions
Follows TYPO3 Core - Bug #32967: Backend workspace copy/cut paste column content fails on publishClosed2012-01-04

Actions
Actions #1

Updated by Michael Stucki almost 12 years ago

I guess that's a duplicate of #39967. Can someone close it, please? (I can't.)

Actions #2

Updated by Falk Kühnel over 11 years ago

I dont think its necessary the same, but it could be.
This seems to happen only on "70 - NEW LOCATION (PLH) WSID#1" items. they do not seem to get the column position info appended somehow.
In all other requests it is something like "70 - NEW LOCATION (PLH) WSID#1x3" for colPos 3.

Michael Stucki wrote:

I guess that's a duplicate of #39967. Can someone close it, please? (I can't.)

Actions #3

Updated by Gerrit Code Review over 11 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18108

Actions #4

Updated by Thorsten Kahler over 11 years ago

Is this resolved by #44470?

Actions #5

Updated by Gerrit Code Review about 11 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #6

Updated by Gerrit Code Review almost 11 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #7

Updated by Gerrit Code Review almost 11 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #8

Updated by Gerrit Code Review over 10 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #9

Updated by Gerrit Code Review over 10 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #10

Updated by Gerrit Code Review over 10 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #11

Updated by Gerrit Code Review over 10 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #12

Updated by Michael Stucki over 10 years ago

  • Category changed from Bugs to Workspaces
Actions #13

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #14

Updated by Gerrit Code Review over 10 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #15

Updated by Gerrit Code Review about 10 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/21097

Actions #16

Updated by Wouter Wolters over 9 years ago

  • Status changed from Under Review to Needs Feedback
  • Is Regression set to No

Hi,

does the problem still exists within newer versions of TYPO3 CMS (6.2.9)?

Actions #17

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #18

Updated by Alexander Opitz almost 9 years ago

What's the state of this issue?

Actions #19

Updated by Riccardo De Contardi over 8 years ago

  • Status changed from Needs Feedback to Closed

I performed a test in both 6.2.15 and 7.5-dev (latest master) and was not able to reproduce it.

I tested both this scenarios:

1) create the element in LIVE workspace > switch to draft workspace > use drag and drop to move it to another column > save
1.1) page preview > the element is in the correct column

2) create the element in CUSTOM (DRAFT) workspace > save it > open it again > change the colpos using the dropdown > save
2.1) page preview > the element is in the correct column

I close this ticket; if you think that this is the wrong decision or experience this issue again or if you think I should perform a different test, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Actions

Also available in: Atom PDF