Project

General

Profile

Actions

Bug #34147

closed

IE8 crashes if list of recipients in Workspace is too long

Added by Thorsten Rath over 12 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2012-02-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When a change is propagated from one stage to the next one, there is a popup to enter a list of e-mail-recipients. If the list of recipients is too long, a scrollbar appears. Using the scrollbar in IE causes the browser to crash.

TYPO3 Version 4.5.7


Files

screen_beforeclic_scrollbar.png (247 KB) screen_beforeclic_scrollbar.png screenshot before clic on scrollbar on IE9 (same on IE10) Olivier SC, 2013-06-14 17:09
screen_afterclic_scrollbar.png (246 KB) screen_afterclic_scrollbar.png screenshot after clic on scrollbar on IE9 (same on IE10) => border around liste, position changed Olivier SC, 2013-06-14 17:09
cattura.png (38.9 KB) cattura.png Riccardo De Contardi, 2017-04-10 10:53

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #81232: Localizing record from default language into other isn't possible with Internet Explorer 11 due to a CSS bug in localisation wizardClosedJasmina LieƟmann2017-05-16

Actions
Actions #1

Updated by Ralf Merz over 12 years ago

Hi,

I can confirm this.
When we have a recipient list that is so long that there is the scrollbar in the popup window, IE8 crashes when you want to scroll (click and move it).+

Regards,
Ralf alias merzilla

Actions #2

Updated by Olivier SC over 11 years ago

Hi,

I can confirm this too.

On IE8, if the recipient list is too long, the scroolbar appear. If I click on it => IE8 crash

On IE9, there is no visible JS error and no crash, but the size of the list change a little (1px visible border around the list)

Tested on :
TYPO3 v 4.5.22
TYPO3 v.4.7.7 (via TYPO3Winstaller)

Steps to reproduce :
1) install a fresh clean TYPO3 (ex : v4.7.7) and add a page and a content in tg
2) add at least 10 users with email (ex : , , etc....)
3) create a new "workspace" (ex : "crashdemo")
4) add the news users in all fields of the new workspace
5) switch to "crashdemo" workspace
6) change a content
7) switch to module "workspace"
8) send the content to "next step"
9) in the popin with the long list of users (and the scrollbar) try to click on scrollbar
10) wait for IE8 to crash :(

On TYPO3 V6.0.2-dev (on http://demo.typo3.org/typo3/ ), with the same steps, IE8 don't crash, but the list is unusable.
You can scroll, but the list don't move.

I hope that could help

Actions #3

Updated by Sascha Egerer about 11 years ago

You should report this to microsoft, don't you? So i think we should close this issue because it is not related to workspaces but to a buggy browser

Updated by Olivier SC about 11 years ago

There is a really strange behaviour on every versions of Internet Explorer (from IE7 to IE10) for this functionality.

For and IE8, the browser crash when you start to use the scrollbar.

For IE7, IE9 and IE10, the browser don't crash but when you start to use the scrollbar, but something change : borders appear around the list and you can't drag the scrollbar anymore. You have to stop dragging (release mouse button) and try it a second time.

For IE9 and IE10, if you clic in another place in the popin (outside the emails list) the style change again and revert to the original style (no more border).
If you try to scroll again, the problem start again (borders change, you have to stop dragging).

For IE7, you can't scroll at all, you must close the popin.

No other list had something like that in TYPO3... so I think strange event is attached to this special item.

Actions #5

Updated by Michael Stucki over 10 years ago

  • Category set to Workspaces
Actions #6

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #7

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #8

Updated by Nicole Cordes almost 9 years ago

  • Status changed from New to Accepted
  • Is Regression set to No

The problem is that the div x-form-check-group x-column-layout-ct x-form-field gets a focus border which has to be removed at least in x-window elements.

Actions #9

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #10

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
Actions #11

Updated by Riccardo De Contardi over 7 years ago

I tested version 8.7.1-dev with IE11 (edge,Windows 7) and the result is that the popup has still issues (albeit different):

See attached image Cattura.png

[Update]

Performed a little investigation: the modal uses display:flex I think it is not well supported by IE11

Actions #12

Updated by Riccardo De Contardi about 7 years ago

  • Related to Bug #81232: Localizing record from default language into other isn't possible with Internet Explorer 11 due to a CSS bug in localisation wizard added
Actions #13

Updated by Riccardo De Contardi about 7 years ago

  • Status changed from Accepted to Closed

I confirm that the issue with IE11 has been solved with https://review.typo3.org/#/c/53113/

I think I can safely close this issue now. If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

Actions

Also available in: Atom PDF