Bug #34886

Task #52304: Performance issues

t3lib_cache_backend_FileBackend don't support 0 has liftime

Added by Dominique Feyer over 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Caching
Target version:
-
Start date:
2012-03-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In the DB backend 0 has liftime mean "unlimited" lifetime for the cache entry, but in the file backend it's give a always invalid cache entry.

Patch is coming


Related issues

Related to TYPO3 Core - Bug #52125: Saving records takes ages to completeClosed2013-09-19

Actions
Related to TYPO3 Core - Feature #39430: Update cache framework to latest FLOW3 versionClosed2014-04-17

Actions
Related to TYPO3 Core - Bug #58008: Autoload cache never expires and is not flushed after installing new extensionClosed2014-04-17

Actions
#1

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9671

#2

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9671

#3

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9671

#4

Updated by Gerrit Code Review over 10 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9671

#5

Updated by Oliver Hader over 10 years ago

Thanks for your patch. How was the behaviour in 4.5 (since your patch only is reported for 4.6 and 4.7). Is it an issue in 4.5 as well?

#6

Updated by Dominique Feyer over 10 years ago

Yes it's an issues in 4.5 also

#7

Updated by Gerrit Code Review almost 10 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9671

#8

Updated by Alexander Opitz about 9 years ago

Hi Dominique,

is this patch still relevant? If yes, can you rebase the patch to current master and add a bit more description to your commit message?

#9

Updated by Christian Kuhn almost 9 years ago

  • Parent task set to #52304
  • Is Regression set to No
#10

Updated by Christian Kuhn almost 9 years ago

This is not an issue in 6.0, it was fixed with #39430

I'm unsure if this issue is still important enough for 4.7 / 4.5

#11

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/24073

#12

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/24073

#13

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/24083

#14

Updated by Dominique Feyer almost 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#15

Updated by Jigal van Hemert about 8 years ago

  • Is Regression changed from No to Yes
#16

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF