Bug #35210

indexed search errors etc. after update

Added by Ben van 't Ende over 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-03-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After the update to 4.7 the search page shows a number of errors starting with:

#1283790586: There is no entry in the $TCA array for the table "index_config". This means that the function enableFields() is called with an invalid table name as argument.

In the backend these errors are shown (4 times):

PHP Warning
PHP Warning: Invalid argument supplied for foreach() in /home/typo3_src/typo3_src-4.7.0beta2/t3lib/l10n/parser/class.t3lib_l10n_parser_llphp.php line 95

Changing the plugin to Indexed Search (Experimental) removes the errors in the frontend, but the ones in the backend remain.

The pagination is gone. Searching does not seem to show the correct results.

The update of Indexed Search seems to be very important with the complaints there are about the slow search.

So both variants there are now do not seem to function as they should.


Related issues

Is duplicate of TYPO3 Core - Bug #32815: Search error in 4.7.0 alpha2 Introduction PackageClosed2011-12-23

Actions
#1

Updated by Ben van 't Ende over 9 years ago

Looks like search markers are not respected when using experimental (<!--TYPO3SEARCH_begin-->)

#2

Updated by Eric Chavaillaz over 9 years ago

I confirm this error after upgrade :

#1283790586: There is no entry in the $TCA array for the table "index_config". This means that the function enableFields() is called with an invalid table name as argument.

If I not use the experimental plugin...

#3

Updated by Anders Gissel over 9 years ago

Bug is present in 4.7 release as well, even after several database compare/updates, and a reinstall just for the heck of it.

#4

Updated by Dietmar Adrian over 9 years ago

For me I found a simple work around under TYPO3 4.7.0:

In file sysext/indexed_search/ext_tables.php: comment two lines:

line 41
#if (t3lib_extMgm::isLoaded('crawler')) {
and line 62
#}

This allows to load table index_config into $TCA even if the crawler extension is not loaded.

#5

Updated by Felix Kopp over 9 years ago

  • Status changed from New to Resolved
#6

Updated by Tomasz Krawczyk over 9 years ago

Could you, please, add this fix to the 4.6 branch? I've noticed this bug in 4.6.12.

#7

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF