Bug #36459

Trouble with pagetree after upgrade from 4.5.14 to 4.5.15

Added by Webadmin no-lastname-given over 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Category:
Pagetree
Target version:
Start date:
2012-04-23
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After Upgrading from 4.5.14 to 4.5.15 every login the pagetree is collapsed completely.

After expanding some nodes and logging out, the state will not be saved. On next login you will again see only the root node.

When flushing the temp userdata this wokrs again, by the userprefs are all lost. This makes some trouble in an evirorement with more than 10 editors.


Related issues

Related to TYPO3 Core - Bug #36238: Pagetree lost for non admin after upgrading to 4.5.15 Closed 2012-04-17

Associated revisions

Revision c0232ce1 (diff)
Added by Stefan Galinski over 7 years ago

[BUGFIX] Pagetree doesn't expands to the last saved state

Change-Id: I0518d9dd06c7d126dfe5d885e4b2751b7e7462b6
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #36459
Reviewed-on: http://review.typo3.org/11138
Reviewed-by: Nicole Cordes
Tested-by: Nicole Cordes
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

Revision 5898559a (diff)
Added by Stefan Galinski over 7 years ago

[BUGFIX] Pagetree doesn't expands to the last saved state

Change-Id: I0518d9dd06c7d126dfe5d885e4b2751b7e7462b6
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #36459
Reviewed-on: http://review.typo3.org/11190
Reviewed-by: Stefan Galinski
Tested-by: Stefan Galinski

Revision a1c09d93 (diff)
Added by Stefan Galinski over 7 years ago

[BUGFIX] Pagetree doesn't expands to the last saved state

Change-Id: I0518d9dd06c7d126dfe5d885e4b2751b7e7462b6
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #36459
Reviewed-on: http://review.typo3.org/11189
Reviewed-by: Stefan Galinski
Tested-by: Stefan Galinski

Revision d8e6613b (diff)
Added by Stefan Galinski over 7 years ago

[BUGFIX] Pagetree doesn't expands to the last saved state

Change-Id: I0518d9dd06c7d126dfe5d885e4b2751b7e7462b6
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #36459
Reviewed-on: http://review.typo3.org/11188
Reviewed-by: Stefan Galinski
Tested-by: Stefan Galinski

Revision 51da6016 (diff)
Added by Stefan Galinski about 7 years ago

[BUGFIX] Pagetree doesn't expands to the last saved state

Change-Id: I0518d9dd06c7d126dfe5d885e4b2751b7e7462b6
Releases: 6.0, 4.7, 4.6, 4.5
Fixes: #36459
Reviewed-on: http://review.typo3.org/11138
Reviewed-by: Nicole Cordes
Tested-by: Nicole Cordes
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Stefan Galinski over 7 years ago

  • Status changed from New to Needs Feedback

Please use the patch from #36238 to fix this issue (and update your database, because a field has changed to store bigger user configurations).

#2 Updated by Stephan Brun over 7 years ago

After Upgrading from 4.5.14 to 4.5.15 there is also a problem with the db-mountpoints inherited form a be-usergroup.
Some don't appear at all and others are not expandable.

Update: Sorry, didn't saw the answer from Stefan Galinski, will try it with the patch from #36238

#3 Updated by Robert Wunsch over 7 years ago

After having a look through the unserialized array in the uc field of be_users table i noticed the following:

This is what gets written to the object:

'Pagetree' => 
      stdClass::__set_state(array(
         'stateHash' => 
        stdClass::__set_state(array(
           'oot' => 1,
           '68-68' => 1,
           'ba-1' => 1,
           '12e-1' => 1,
           '131-1' => 1,
           '14c-1' => 1,
           '1-1' => 1,
        )),
      )),

I guess that the line

'oot' => 1,

should be

'*r*oot' => 1,

but I do not have a clue where the object is assembled and written.

I tested the following:

- Logged in as a normal user and the pagetree would not open
- Opened the user in the database and edited the us filed according to the info on top.
- Logged in with the user again and the pagetree opended.

I have a stron notion that the problem is related to the pagetree top element being 'oot' not 'root'.

#4 Updated by Stefan Galinski over 7 years ago

  • Status changed from Needs Feedback to Accepted

Thanks for your investigation!

#5 Updated by Stefan Galinski over 7 years ago

  • Assignee set to Stefan Galinski

#6 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/11138

#7 Updated by Stefan Galinski over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Gerrit Code Review over 7 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/11188

#9 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/11189

#10 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/11190

#11 Updated by Stefan Galinski over 7 years ago

  • Status changed from Under Review to Resolved

#12 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF