Bug #36894

[felogin] Wrong action url when nested array is passed

Added by Tymoteusz Motylewski over 9 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-05-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have login form on page with url like this:
index.php?id=10&L=3&tx_someext[@widget_0][currentPage]=3

Action url of login form will point to:
index.php?id=10&L=3&tx_someext[@widget_0]=Array

The problem is in method tx_felogin_pi1->getPreserveGetVars() (called from getPageLink() ).
This method assumes that no nested arrays are passed as parameter.

$params .= '&' . $key . '[' . $key1 . ']=' . $val1;


Files

felogin.patch (2.03 KB) felogin.patch felogin Patch Horst Prote, 2012-05-23 16:30
felogin.patch (2.18 KB) felogin.patch Horst Prote, 2012-05-25 15:11

Related issues

Related to TYPO3 Core - Bug #23324: getPreserveGetVars does not work as expectedClosed2010-07-31

Actions
Related to TYPO3 Core - Bug #19938: warning: in_array wrong datatypeClosed2009-01-30

Actions
Has duplicate TYPO3 Core - Bug #48005: getPreserveGetVars does not work with nested arraysRejected2013-05-07

Actions

Also available in: Atom PDF