Bug #38767

Epic #65814: Make Indexed search extbase plugin shine

Incorrect order of search-result

Added by Mats Svensson about 7 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2012-07-09
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The function execFinalQuery in pi/class.tx_indexedsearch.php, doesn't use the searched word(s) in exec_SELECTquery where filter anymore, so freq gets wrong.


Related issues

Related to TYPO3 Core - Bug #36944: Rating doesn't show at all Closed 2012-05-08
Related to TYPO3 Core - Bug #58134: None of order is kept in indexed_search when using mysql hook Closed 2014-04-23
Related to TYPO3 Core - Bug #67843: Wrong queries in indexSearchRepository Closed 2015-06-30
Duplicated by TYPO3 Core - Bug #44600: Results doesn't honour the flagBitMask and so the order is wrong Closed 2013-01-17
Duplicated by TYPO3 Core - Bug #52219: indexed_search shows always 100% in search results in TYPO3 4.7 Closed 2013-09-24

Associated revisions

Revision b96eaa47 (diff)
Added by Ralf Hettinger over 5 years ago

[BUGFIX] use search word(s) for ordering search results (again)

There has been a regression in http://review.typo3.org/6657 which
removes correlation between searched words and ordering of search
results. Therefore the ordering of search results had nothing to do
with the search term anymore. This is fixed hereby by using the code
parts from prior versions.

Resolves: #38767
Releases: 6.2, 6.1, 6.0, 4.7
Change-Id: I9cfaceaeede38456dd7622085879c1bd0648be85
Reviewed-on: https://review.typo3.org/20294
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader
Reviewed-by: Wouter Wolters
Reviewed-by: Markus Klein
Tested-by: Markus Klein

Revision a31b3252 (diff)
Added by Ralf Hettinger over 5 years ago

[BUGFIX] use search word(s) for ordering search results (again)

There has been a regression in http://review.typo3.org/6657 which
removes correlation between searched words and ordering of search
results. Therefore the ordering of search results had nothing to do
with the search term anymore. This is fixed hereby by using the code
parts from prior versions.

Resolves: #38767
Releases: 6.2, 6.1, 6.0, 4.7
Change-Id: I9cfaceaeede38456dd7622085879c1bd0648be85
Reviewed-on: https://review.typo3.org/26706
Reviewed-by: Markus Klein
Tested-by: Markus Klein

Revision 583a51b8 (diff)
Added by Ralf Hettinger over 5 years ago

[BUGFIX] use search word(s) for ordering search results (again)

There has been a regression in http://review.typo3.org/6657 which
removes correlation between searched words and ordering of search
results. Therefore the ordering of search results had nothing to do
with the search term anymore. This is fixed hereby by using the code
parts from prior versions.

Resolves: #38767
Releases: 6.2, 6.1, 6.0, 4.7
Change-Id: I9cfaceaeede38456dd7622085879c1bd0648be85
Reviewed-on: https://review.typo3.org/26707
Reviewed-by: Markus Klein
Tested-by: Markus Klein

Revision 66bb3503 (diff)
Added by Ralf Hettinger over 5 years ago

[BUGFIX] use search word(s) for ordering search results (again)

There has been a regression in http://review.typo3.org/6657 which
removes correlation between searched words and ordering of search
results. Therefore the ordering of search results had nothing to do
with the search term anymore. This is fixed hereby by using the code
parts from prior versions.

Resolves: #38767
Releases: 6.2, 6.1, 6.0, 4.7
Change-Id: I9cfaceaeede38456dd7622085879c1bd0648be85
Reviewed-on: https://review.typo3.org/26708
Reviewed-by: Markus Klein
Tested-by: Markus Klein

History

#1 Updated by Oliver Hader over 6 years ago

  • Target version set to 2222

#2 Updated by Oliver Hader over 6 years ago

  • Project changed from Indexed Search to TYPO3 Core

#3 Updated by Oliver Hader over 6 years ago

  • Category set to Indexed Search

#4 Updated by Oliver Hader over 6 years ago

  • Target version deleted (2222)

#5 Updated by Ralf Hettinger over 6 years ago

Unfortunately, I can confirm this. Due to this bug indexed_search is rather useless imo: Ordering of results has nothing to do with the searched word(s) anymore :(
The following order settings are affected: rank_flag, rank_freq, rank_first, rank_count

An obvious consequence next to the wrong ordering of results: ###RATING### is being filled with nonsense. It is always 100% for rank_flag and rank_freq. And contains a quite large number for rank_count. For rank_first it's wrong, too, but that's not so obvious here. Thus, #44600 might be a duplicate of this one.

#6 Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20294

#7 Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20294

#8 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26706

#9 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26707

#10 Updated by Gerrit Code Review over 5 years ago

Patch set 1 for branch TYPO3_4-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/26708

#11 Updated by Anonymous over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Gerhard Rupp about 4 years ago

These changes should also be applied to the Extbase based version of indexed search (experimental mode)

#13 Updated by Tymoteusz Motylewski about 4 years ago

  • Status changed from Resolved to New
  • TYPO3 Version set to 7
  • Is Regression set to No

Thanks for reporting, I'm reopening the issue

#14 Updated by Tymoteusz Motylewski about 4 years ago

  • Parent task set to #65814

#15 Updated by Tymoteusz Motylewski over 3 years ago

  • Status changed from New to Resolved
  • TYPO3 Version changed from 7 to 6.2

already fixed for extbase in http://review.typo3.org/38130, so it made it to 6.2

#16 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF