Project

General

Profile

Actions

Bug #39139

closed

Decouple backend task execution from backend

Added by Christian Kuhn almost 12 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
scheduler
Target version:
Start date:
2012-07-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

It would be cool, if a task is executed through the backend, that then a new process in cli context is executed (eg. via exec()).

This would have mulptiple advantages:
  • No scope change anymore if a task is executed via cli_dispatch.php or the backend
  • No fatal error in the backend module if a task fatals
  • Far easier scoping within extbase based tasks (see related issues).

See also the comment for patch https://review.typo3.org/#/c/9517/


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Feature #45537: Run manually executed tasks on next cron-runClosedMichael Oehlhof2013-02-16

Actions
Is duplicate of TYPO3 Core - Feature #49379: Run scheduler tasks with proper userRejected2013-06-24

Actions
Actions #1

Updated by Philipp Gampe over 11 years ago

I guess that is a task for 6.1?

Actions #2

Updated by Christian Kuhn over 11 years ago

yes, maybe even later ... maybe some other core things like a real context concept in typo3 bootstrap should also be done first? this ticket is for now only here to document the need at all.

Actions #3

Updated by Stefan Neufeind over 11 years ago

What would partially resolve this would be running manually started tasks on next cron-run. I've filed separate issue #45537 for that.

But I agree that even if called directly maybe calling the scheduler by exec() might be a good idea.

Do we have the correct syntax on how to call PHP somehow already? Or would we need a setting in the installer to (optionally) specify path and name of the php-binary? If not set we could attempt an auto-detection (let system search for "php" in the path).

Actions #4

Updated by Michael Stucki over 10 years ago

  • Category set to scheduler
Actions #5

Updated by Michael Stucki over 10 years ago

  • Project changed from 739 to TYPO3 Core
  • Category changed from scheduler to scheduler
Actions #6

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
  • TYPO3 Version set to 6.2
  • Is Regression set to No
Actions #7

Updated by Stefan Neufeind over 9 years ago

If we run it via exec we'll have a proper cli-context. But if I'm right there will still be max-execution (since the calling PHP-process will die at some point). Could that be? And if so, might it be a better idea to just re-schedule the job to fire at the next regular cron-execution (intention of #45537). But we might even go both ways and have that configurable, so that if you only run via cron every 30min or so you could still do the manual invocation immediately as described here.

Actions #8

Updated by Benni Mack over 8 years ago

  • Assignee set to Benni Mack
  • Target version changed from 7.5 to 8 LTS

yes. we should call it via exec or schedule it separately. I don't know how much effort this will take, but would solve a lot of problems.

Actions #9

Updated by Christian Kuhn over 8 years ago

  • Status changed from New to Closed

resolved as dupe of #49379

Actions

Also available in: Atom PDF