Bug #40397

When localizing a content element, relations to images are lost

Added by Lorenz Ulrich over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2012-08-30
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm using TYPO3 6.0 alpha 3.

When I localize content elements with "Copy content elements from default language", the localized version of the CE loses all relations to the FAL images.

Might be an IRRE problem. I didn't find any reports about this yet.


Related issues

Is duplicate of TYPO3 Core - Task #40608: Make sys_file_reference table translateableClosedSteffen Ritter2012-09-04

Actions
#1

Updated by Andreas Wolf over 8 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Accepted
#2

Updated by Thomas Löffler over 8 years ago

It seems to be a problem with the DataHandler and the method localize().
In TCA there is the "old" field "mergeIfNotBlank" which copied the comma separated image strings into the new element.
WIth FAL there is a need of handling the new references.

#3

Updated by Steffen Ritter over 8 years ago

  • Status changed from Accepted to Under Review
#4

Updated by Steffen Ritter over 8 years ago

  • Assignee set to Steffen Ritter
#5

Updated by Helmut Hummel over 8 years ago

  • Status changed from Under Review to Resolved
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF