Bug #40573

#1270853879: TYPO3 Fatal Error: Extension key "t_y_p_o3.c_m_s.lang" is NOT loaded!

Added by Simon Schaufelberger almost 9 years ago. Updated over 6 years ago.

Must have
Target version:
Start date:
Due date:
% Done:


Estimated time:
TYPO3 Version:
PHP Version:
Is Regression:
Sprint Focus:


i have a local typo3 trunk and i have used it for a long time. i just pull new changes via git and now i get the following error when calling the backend:

#1270853879: TYPO3 Fatal Error: Extension key "t_y_p_o3.c_m_s.lang" is NOT loaded!


7 TYPO3\CMS\Core\Extension\ExtensionManager::extRelPath("t_y_p_o3.c_m_s.lang")
6 TYPO3\CMS\Extbase\Utility\ExtensionUtility::registerModule("TYPO3.CMS.lang", "tools", "language", "after:extensionmanager", array, array)
5 require("C:\xampp\htdocs\typo3v4core\htdocs\typo3\sysext\lang\ext_tables.php")
4 TYPO3\CMS\Core\Extension\ExtensionManager::loadSingleExtTablesFiles()
3 TYPO3\CMS\Core\Extension\ExtensionManager::loadExtTables(boolean)
2 TYPO3\CMS\Core\Core\Bootstrap::loadExtensionTables(boolean)
1 require("C:\[...]\htdocs\typo3\init.php")

i then tried to call the install tool directly which works and go through the upgrade wizard but there i get a crash as well on the first step:

Install Outsourced System Extensions

Class tx_em_Connection_ExtDirectServer does not exist

Guys, this does not look like a "stable" core that can be deployed...


Updated by Markus Klein almost 9 years ago

Did you clean typo3temp/Cache and your browser cache?


Updated by Simon Schaufelberger almost 9 years ago

yes sure, multiple times.

if i add "lang" to the extension list, then it works but why did it disappear? i never uninstalled "lang"...

even if i fix that, i still get the "Class tx_em_Connection_ExtDirectServer does not exist " error in the install tool.


Updated by Sebastian Michaelsen almost 9 years ago

I can confirm this issue.

Have a look at \TYPO3\CMS\Install\Updates\AbstractUpdate line 149:
$extensionManagerConnection = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('tx_em_Connection_ExtDirectServer', FALSE);

This class does not exist (anymore?).


Updated by Wouter Wolters over 8 years ago

No reference found for tx_em_Connection_ExtDirectServer in AbstractUpdate. AFAICS this is fixed in current master


Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Closed
  • Is Regression set to No

is this still relevant? If so, please re-open the ticket

Also available in: Atom PDF