Bug #40795

Task #40095: Move core to namespaces

Exception in TCA tree after Namespace changes

Added by Mario Rimann about 9 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2012-09-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When trying to create a new "News Category" record in the list module, the following Exception is thrown:

#1: PHP Catchable Fatal Error: Argument 1 passed to TYPO3\CMS\Backend\Tree\AbstractTree::setNodeRenderer() must be an instance of
t3lib_tree_renderer_Abstract, instance of TYPO3\CMS\Core\Tree\TableConfiguration\ExtJsArrayTreeRenderer given, called in
C:\xampp\htdocs\currenttruk\typo3\sysext\backend\Classes\Form\Element\TreeElement.php on line 91 and defined in
C:\xampp\htdocs\currenttrunk\typo3\sysext\backend\Classes\Tree\AbstractTree.php line 7

This happens with current TYPO3-Core from Git (6.0-dev) and current Git-Version from tx_news (but seems to be a bug in the core, since the extension only tries to use a field-type from TCA).

#1

Updated by Claus Due about 9 years ago

Note, this appears to happen because t3lib_tree_renderer_Abstract is no longer part of the inheritance tree for \TYPO3\CMS\Backend\Tree\AbstractTree.

It will no longer be possible to check for implementations of parent classes and interfaces (in a way that works equally on pre-6.0 and 6.0). Sorry guys.

#2

Updated by Tymoteusz Motylewski about 9 years ago

this is indeed bug in core
method
TYPO3\CMS\Backend\Tree\AbstractTree::setNodeRenderer [1]
is defined as:
public function setNodeRenderer(\t3lib_tree_renderer_Abstract $nodeRenderer) {

but it should use namespaced class name

[1]
http://git.typo3.org/TYPO3v4/Core.git?a=blob;f=typo3/sysext/backend/Classes/Tree/AbstractTree.php;h=0e5df96e5ca15f44e7a1d1d673830b4301bf3ad1;hb=master

#3

Updated by Gerrit Code Review about 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14508

#4

Updated by Georg Ringer about 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Christian Kuhn about 9 years ago

  • Parent task set to #40095
#6

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF