Bug #40814

Task #40095: Move core to namespaces

Exception in TCA tree after Namespace changes (part 2)

Added by Mario Rimann about 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2012-09-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Same problem as with #40795 - but that change was merged before I could give a feedback during the review.

The message of the exception changed a bit after the change introduced with #40795:

#1: PHP Catchable Fatal Error: Argument 1 passed to TYPO3\CMS\Backend\Tree\AbstractTree::setNodeRenderer() must be an instance of
TYPO3\CMS\Backend\Tree\Renderer\AbstractTree, instance of TYPO3\CMS\Core\Tree\TableConfiguration\ExtJsArrayTreeRenderer given,
called in /path/to/typo3_src/typo3/sysext/backend/Classes/Form/Element/TreeElement.php on line 91 and defined in
/path/to/typo3_src/typo3/sysext/backend/Classes/Tree/AbstractTree.php line 71

Steps to reproduce:
- Install EXT:news (as it makes use of the tcatree-feature)
- Go to List module
- Add a record of type "News Category"

Expected:
- Form for creating a News Category is shown

Current:
- the above mentioned Exception is shown

#1

Updated by Helmut Hummel almost 9 years ago

  • Parent task set to #40095
#2

Updated by Wouter Wolters almost 9 years ago

Mario: AFAIK this is already fixed in master. Can you verify if the problem is solved?

#3

Updated by Mario Rimann almost 9 years ago

Wouter Wolters wrote:

Mario: AFAIK this is already fixed in master. Can you verify if the problem is solved?

Just verified: You're right, problem is solved on a clean master with current tx_news version.

#4

Updated by Steffen Ritter almost 9 years ago

  • Status changed from New to Rejected

no fix needed anymore

Also available in: Atom PDF