Bug #42225

IRRE: AJAX Feature breaks Header-Toolbar

Added by Steffen Ritter over 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2012-10-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

IRRE is Loading Child-Records on demand via AJAX.

As long as the Record is not only the "form and their elements" are missing but also the hidden fields which actually store the data.

The header controls of IRRE such as hide and delete do not actually "hide or delete" the record, but just set the field value of the record to accordingly.

This especially means, that as long as the fields are not rendered (e.g. the element has been expanded) these actions do not take any result on database level - even though the grafical effect (like fade out or switch of bulb) show this to the user.

Furthermore the same effect happens if the hidden field is just not rendered into the form.

Either the Header-Toolbar has to be decoupled from the rendered form data, or a minimal set of fields (e.g. tca and control fields) have to be rendered everytime (even for collapsed records).

This makes FAL handling quite uncomfy.


Related issues

Related to TYPO3 Core - Bug #44208: Tree not show in inline collapseClosedMathias Schreiber2012-12-24

Actions
#1

Updated by Marcel Burkhalter over 8 years ago

As a workaround we inserted the following code into extTables.php:

$TCA['pages']['columns']['media']['config']['appearance']['collapseAll'] = FALSE;
$TCA['pages_language_overlay']['columns']['media']['config']['appearance']['collapseAll'] = FALSE;
$TCA['tt_content']['columns']['image']['config']['appearance']['collapseAll'] = FALSE;
$TCA['tt_content']['columns']['media']['config']['appearance']['collapseAll'] = FALSE;
$TCA['sys_file_collection']['columns']['files']['config']['appearance']['collapseAll'] = FALSE;

#2

Updated by Marcel Burkhalter almost 8 years ago

Does this issue still persist? We just tried to hide/delete FAL IREE records without the above workaround using 6.1.1 and it worked perfectly.

#3

Updated by Mathias Schreiber about 6 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

can't reproduce, closing

Also available in: Atom PDF