Bug #43484

Extension Manager only shows error message "File has been deleted."

Added by Heinz Scheungrab almost 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2012-11-30
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

There is a error message, when i run the extension manager:

Oops, an error occurred!
File has been deleted.
More information regarding this error might be available online.

Associated revisions

Revision 03f40e4d (diff)
Added by Georg Ringer almost 7 years ago

[BUGFIX] Catch all errors in EM ViewHelper

Catching all errors which can happen during image generation
to avoid a non caught exception for users.

Problem is especially the Exception "File has been deleted"
which happens at some sites when having empty
typo3temp/_processed_/ directory and empty sys_file DB table.

Change-Id: I5f4e9ce520c828c222f91a2a816263cd433c5c60
Fixes: #43484
Releases: 6.1, 6.0
Reviewed-on: http://review.typo3.org/16993
Reviewed-by: Mattias Nilsson
Tested-by: Wolfgang Freund
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

Revision db79f0f0 (diff)
Added by Georg Ringer almost 7 years ago

[BUGFIX] Catch all errors in EM ViewHelper

Catching all errors which can happen during image generation
to avoid a non caught exception for users.

Problem is especially the Exception "File has been deleted"
which happens at some sites when having empty
typo3temp/_processed_/ directory and empty sys_file DB table.

Change-Id: I5f4e9ce520c828c222f91a2a816263cd433c5c60
Fixes: #43484
Releases: 6.1, 6.0
Reviewed-on: http://review.typo3.org/17002
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer

History

#1 Updated by Chris topher almost 7 years ago

  • Subject changed from Extension Manager to Extension Manager only shows error message "File has been deleted."

#2 Updated by Hartmut Steglich almost 7 years ago

can confirm this for TYPO3 6.0.0; was ok until 6.0.0RC2

#3 Updated by Heinz Scheungrab almost 7 years ago

The same error on some content pages.

LOG:
Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1329821485: File has been deleted. | RuntimeException thrown in file /.../typo3_src-6.0.0/typo3/sysext/core/Classes/Resource/AbstractFile.php in line 492. Requested URL: http://.../typo3/sysext/cms/layout/db_layout.php?id=322

The extension manager works after deleting typo3temp and all caches.

#4 Updated by Hartmut Steglich almost 7 years ago

completely deleted typo3temp, did not help

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1329821485: File has been deleted. | RuntimeException thrown in file .../typo3/sysext/core/Classes/Resource/AbstractFile.php in line 492. Requested URL: http://.../typo3/mod.php?M=tools_ExtensionmanagerExtensionmanager

#5 Updated by Cedric Ziel almost 7 years ago

On my side, this error doesn't happen, if your sources aren't symlinked.

#7 Updated by Sebastian almost 7 years ago

My sources aren't symlinked - nevertheless the error occurs on my side

#8 Updated by Wolfgang Rock almost 7 years ago

Can confirm Sebastian: My sources are not symlinked and the error occurs. Emptying typo3temp and clearing caches does not help!

#9 Updated by Sebastian almost 7 years ago

After yesterday, clearing caches, typo3temp (completely)
the extension manager now works!

No change in files, directories or database!

Guess the problem solved itself? (refreshed system-entrys in db?)

Hartmut, Heinz and Peter can you verify this behavior?
Wolfgang, please give a feedback tomorrow.

#10 Updated by Heinz Scheungrab almost 7 years ago

@Sebastian: The same on my site. No changes > em works fine. But on some pages the same error inside the page-modul.

#11 Updated by Wolfgang Freund almost 7 years ago

Error also occurs on 6.1-dev version from git.

Sources are symlinked. Clearing caches or typo3temp folder does not help.

#12 Updated by Hartmut Steglich almost 7 years ago

strange behaviour here:

yesterday - again deleted typo3temp completely, em only showing debug output which I wanted to post now

today - em shows up, lists installed and available ext => seems to work ok, but icons of exts are mixed up

could ist be related to login/logout? nothing else changed inbetween.

installation was updated 4.7.x -> 6.0.0RC1 -> 6.0.0RC2 -> 6.0.0
sources are not symlinked

#13 Updated by Frank Schumacher almost 7 years ago

Same issue here. Clean installation of 6.0 on W2008 DataCenter Server. Earlier that day, the em showed up, but only showed the installed extensions. The Get Extension List was empty. Eventually, when I returned to em, I get this error. I tried clearing cache, reloging, restarting apache/mysql, restarting whole server. Nothing helped.
I think what I have done in the meantime (beside creating a simple site with some text and 2 pictures) was installing and configuring ImageMagick. Not sure, wheter this may be related somehow.

And I am using symlinks

#14 Updated by Georg Ringer almost 7 years ago

  • Status changed from New to Accepted
  • Assignee set to Georg Ringer
  • Target version set to 6.0.1
  • Complexity set to no-brainer

#15 Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16993

#16 Updated by Georg Ringer almost 7 years ago

please test the bugfix, change is a 1line. and give feedback in gerrit

#17 Updated by Heinz Scheungrab almost 7 years ago

After bugfix > The em works fine, but when i go to "get extension" >

Oops, an error occurred!
Could not analyse class:TYPO3\CMS\Extensionmanager\ViewHelpers\ShowExtensionVersionsViewHelper maybe not loaded or no autoloader?
More information regarding this error might be available online.

#18 Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at http://review.typo3.org/17002

#19 Updated by Georg Ringer almost 7 years ago

i just merged the proposed patch.

@Heinz: Can I get access to your system including ssh or ftp? I can't reproduce it but I still wanna fix it. thx

#20 Updated by Georg Ringer almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#21 Updated by Heinz Scheungrab almost 7 years ago

After including the patch > Error still exist.

@Georg: Of course you can get access to my system - Where can i post the login data?

#22 Updated by Dirk Reitz almost 7 years ago

@Georg

unfortunately your patch didn't help ... now all i get is a white screen, when I try to open the em. BTW - the same happens, if I would like to open 'language'.

brgds Dirk

#23 Updated by Christian Ehret almost 7 years ago

Hello,

I had the same issue here. I changed typo3/sysext/core/Classes/Resource/AbstractFile.php to get an idea what's missing:
Line 492: throw new \RuntimeException('File has been deleted. '.$this->name, 1329821485);

so I got the following log entry:
Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1329821485: File has been deleted. csm_ext_icon_e586462cea.png | RuntimeException thrown in file .....

As others mentioned, clearing cache does not help. But for me it helped to go to install tool - Clean up - and Clean up everything at Number cached image sizes. After that the error has gone!

@Georg: if you need access please let me know!

Christian

#24 Updated by Martin W. almost 7 years ago

I had this error, after I moved an installation to an other server. It appeared in the frontend and in the backend as well. After I emptied the table "sys_file_processedfile" everything runs fine. Maybe the fields "checksum" or "originalfilesha1" caused the error. The filedate changed on the new server.

#25 Updated by Urs Braem almost 7 years ago

Christian Ehret's trick

But for me it helped to go to install tool - Clean up - and Clean up everything at Number cached image sizes. After that the error has gone!

worked for me as well

#26 Updated by Hitesh Anjara almost 7 years ago

MGW wrote:

I had this error, after I moved an installation to an other server. It appeared in the frontend and in the backend as well. After I emptied the table "sys_file_processedfile" everything runs fine. Maybe the fields "checksum" or "originalfilesha1" caused the error. The filedate changed on the new server.

Thank you for this solution, its working greattttttttttt! :-)

#27 Updated by Camelia M almost 7 years ago

Martin Waue wrote:

I had this error, after I moved an installation to an other server. It appeared in the frontend and in the backend as well. After I emptied the table "sys_file_processedfile" everything runs fine. Maybe the fields "checksum" or "originalfilesha1" caused the error. The filedate changed on the new server.

Works for me also. Thanks

#28 Updated by Björn Biege over 6 years ago

Martin Waue wrote:

I had this error, after I moved an installation to an other server. It appeared in the frontend and in the backend as well. After I emptied the table "sys_file_processedfile" everything runs fine. Maybe the fields "checksum" or "originalfilesha1" caused the error. The filedate changed on the new server.

Thank you. I have the issue, after some problems with Image Magic and rendering of images and thumbnails.

#29 Updated by Tilo Baller over 6 years ago

The origin of the Bug was fixed here:
http://forge.typo3.org/issues/44073 (->https://review.typo3.org/#/c/17208/)

As long as 6.0.1 is not released, truncating the sys_file_processedfile table also does the job.

#30 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF