Bug #44643

Error when overwriting FAL file with flash uploader using IE9

Added by Marcel Burkhalter over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-01-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Win7, IE9:
- Upload file in filelist using flash uploader
- Upload updated version of the same file (same filename) with the flash upload (overwrite checked)
- Flash upload does not disappear by itself (that's another thing...)
- Click on the folder containing the file

--> The following error is shown as flash message:
1: No unique filename available in "/user_upload/foo/bar/"!

Overwriting the file does work.

Using FF18 with flash: no error message
Disabling the flash uploader and using old school form to upload: no error message

Tested with 2 days old 6.0.1-dev version.

#1

Updated by Marcel Burkhalter over 8 years ago

Correction: When using the flash uploader under IE9 the file does NOT get overwritten when you see the error 1: No unique filename available in "/user_upload/foo/bar/"!

#2

Updated by Christian Eßl about 8 years ago

Same here in TYPO3 6.0.2.

This happens only in IE9. Also, overriding files IE8 and IE7 works as expected.

#3

Updated by Michael Stucki about 8 years ago

  • Category set to Backend User Interface
#4

Updated by Xavier Perseguers about 8 years ago

I suddenly have this error in 6.0-dev, with both FlashUploader and legacy uploader with Firefox ?!?

Info: I did not check "overwrite existing file" and I expect a new unique name to be generated automatically just as in older versions of TYPO3.

#5

Updated by Patrick Tietz almost 8 years ago

  • Target version set to 6.1.1

Have that problem, too, on 6.1 while using t3lib_extFileFunctions.
I think the problem is in /typo3/sysext/core/Classes/Utility/File/ExtendedFileUtility.php 922 (on 6.1.0) where the comment says "@todo can be improved towards conflict mode naming".
The conflict mode "changeName" is missing, which is default parameter of /typo3/sysext/core/Classes/Resource/ResourceStorage.php / addFile() / line 710.
But only "replace" or "cancel" is passed depending on ExtendedFileUtility::dontCheckForUnique

Here's a little workaround for now:
$basicFileUtil = \TYPO3\CMS\Core\Utility\GeneralUtility::makeInstance('TYPO3\\CMS\\Core\\Utility\\File\\BasicFileUtility');
$uniqueName = $basicFileUtil->getUniqueName( $_FILES['upload_' . $fileIndex]['name'], $this->origImgPath );
$_FILES['upload
' . $fileIndex]['name'] = basename( $uniqueName );

#6

Updated by Eric Chavaillaz almost 8 years ago

Same problem for me with TYPO3 6.1.1 and the EXT:sfdropbox.

When I try to upload a file without the "Ecraser les fichiers existants" flag...

I got this error :

1: No unique filename available in "/"!

Thanks

#7

Updated by Andrea Herzog-Kienast over 7 years ago

Same problem for me with TYPO3 6.1.5 and the EXT:news

When I try to upload a file in FAL

I got this error :

1: No unique filename available in "/"!

Same problem if I upload the file directly.

It ist not a problem with extensions. I can't use any kind of image, even if it is in the file system.
And it is not the browser.

Best,

Andrea

#8

Updated by Andrea Herzog-Kienast over 7 years ago

Some problems fixed - Problems with l10nmgr. Images will now work, if they are still in FAL. Upload in FAL will not work. Images uploaded with ftp will not be shown in filelist, in the backend.

#9

Updated by Wouter Wolters over 6 years ago

  • Status changed from New to Needs Feedback
  • Is Regression set to No

Hi,

The flashuploader has been removed from the core. Is this still a problem with 6.2.9?

#10

Updated by Ingo Schmitt over 6 years ago

  • Category changed from Backend User Interface to File Abstraction Layer (FAL)
  • Sprint Focus set to On Location Sprint
#11

Updated by Ingo Schmitt over 6 years ago

  • Target version changed from 6.1.1 to next-patchlevel
  • TYPO3 Version changed from 6.0 to 6.2

Testing Required.

#12

Updated by Andrea Herzog-Kienast about 6 years ago

Can be closed. Upload in FAL with overwriting works fine. Flashupoloader does not exist any more.
Tested with IE9.

#13

Updated by Ingo Schmitt about 6 years ago

  • Status changed from Needs Feedback to Closed
#14

Updated by Anja Leichsenring over 5 years ago

  • Sprint Focus deleted (On Location Sprint)

Also available in: Atom PDF