Bug #44752

migrated files are not in filelist (tt_content-images , pages-media) - be_user (non admin !?)

Added by daniel rohr over 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2013-01-23
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

i've done an update to 6.0 and migrated images with the upgrade-wizard.

i can edit (sort, meta, etc..) the images as admin but NOT as normal be_user.
is's possible to add new images but no way to see or delete the migrated images as non-admin

tried with new filemounts in the be_group, but i cant get any solution

3images.png View (6.3 KB) daniel rohr, 2013-01-23 15:40

just_one.png View (7.03 KB) daniel rohr, 2013-01-23 15:40

ok4admin.png View (8.09 KB) daniel rohr, 2013-01-23 15:40

set-pids.php View (1.97 KB) Christian Bernet, 2013-02-22 08:38

set-pids.php View - Fixed support for upload-tt_content elements (2.04 KB) Simon Schick, 2013-03-04 17:27


Related issues

Duplicated by TYPO3 Core - Bug #46497: FAL Upgrade Wizard does not set the pid / sys_file_reference is placed on rootlevel Closed 2013-03-21

History

#1 Updated by daniel rohr over 6 years ago

duplicate entry! http://forge.typo3.org/issues/44751
i'm sorry

daniel rohr wrote:

i've done an update to 6.0 and migrated images with the upgrade-wizard.

i can edit (sort, meta, etc..) the images as admin but NOT as normal be_user.
is's possible to add new images but no way to see or delete the migrated images as non-admin

tried with new filemounts in the be_group, but i cant get any solution

#2 Updated by daniel rohr over 6 years ago

the problem was:

sys_file_reference got the pid=0 after migration

daniel rohr wrote:

i've done an update to 6.0 and migrated images with the upgrade-wizard.

i can edit (sort, meta, etc..) the images as admin but NOT as normal be_user.
is's possible to add new images but no way to see or delete the migrated images as non-admin

tried with new filemounts in the be_group, but i cant get any solution

#3 Updated by Stefan Froemken over 6 years ago

Maybe this solves it:

In typo3/sysext/install/Classes/Updates/TceformsUpdateWizard.php near line 260 you can add following:

if (isset($row['pid'])) {
    $fields['pid'] = $row['pid'];
}

After that, go into Installtool -> Update and migrate images again.

I don't have a migrateded system here, so I don't know if it works/helps. Maybe I can prepare a patch when my developer version works again.

Stefan

#4 Updated by Christian Bernet over 6 years ago

We have tested this bugfix and it works partly.
With this patch the images in content will get the right pid.
But the images form the pages will still get the pid 0.
I wrote a script (is attached) that will generate the pids correctly, for those (like me) who can't run the wizzard again.

Christian

#5 Updated by Simon Schick over 6 years ago

Thanks @ChristianBernet for providing the script.
I wrote a fix for the migration-tool an a bad work-around if you already run the migration wizzard (see #45817).

Now it's up to the developers ... Please do something like this:
  1. Fix the bug in the repo by using my patch and test if it works in all ways
  2. Test the set-pids-script and provide a link to it in the ChangeLog.

And do it quickly ... before other people are migrating and having these issue.

Bye
Simon

#6 Updated by Henrik Ziegenhain over 6 years ago

Jeb, the attached script worked for me afer I already migrated to FAL.

We should bring this asap to the core.

#7 Updated by Simon Schick over 6 years ago

@ChristianBernet:
I've updated your script to update tt_content elements of the type upload as well. I updated it in addition for a better console-output because I think (depending on your database) this could may take some time and thereby exceed your time-limit.
This is the only thing I found missing.

#8 Updated by Helmut Hummel over 6 years ago

  • Project changed from File Abstraction Layer to TYPO3 Core

#9 Updated by Helmut Hummel over 6 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Accepted
  • Target version set to 6.0.5
  • TYPO3 Version set to 6.0

#10 Updated by Little Joe over 6 years ago

Have the same problem.
Where do I integrate the file "set-pid.php" ?

#11 Updated by Simon Schick over 6 years ago

@LittleJoe:

This file does not need to be integrated into your TYPO3 project. Just adjust the connection details to your database (hostname, username, password and database) and open it.
Either from the commandline by calling php set-pid.php or using your webserver - like an usual website.

#12 Updated by Little Joe over 6 years ago

Wow, worked perfect! Thank you so much!!!

#13 Updated by Mathias Schreiber over 4 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

Also available in: Atom PDF