Bug #45265

Single tasks are broken

Added by Philipp Gampe over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
scheduler
Target version:
-
Start date:
2013-02-08
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There are several issue with single tasks

  • If an enddate is set, saving the task without the disabled checkbox will result in an exception http://wiki.typo3.org/Exception/v4/1250715544
  • If a next execution is set, but it is after enddate, then the task will always be shown as late
  • switching from a recurring task to a single task will likely result in strange situations

The save action must make sure to clear related fields before saving the task.

The next execution time function must also handle the endtime error more gracefully --> another issue.


Related issues

Related to TYPO3 Core - Feature #34227: Scheduler: Allow execution using "at"-daemonClosedStefan Neufeind2012-02-24

Actions
#1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18106

#2

Updated by Andreas Wolf over 8 years ago

I'm sorry, but I could not reproduce this on current master...

#3

Updated by Philipp Gampe over 8 years ago

You need to enable the use of the at daemon in the scheduler extension settings and you need the at daemon on your test system.

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18106

#5

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/18106

#6

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/18173

#7

Updated by Anonymous over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master_new has been pushed to the review server.
It is available at https://review.typo3.org/18639

#9

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
#10

Updated by Michael Stucki over 7 years ago

  • Category set to scheduler
#11

Updated by Michael Stucki over 7 years ago

  • Project changed from 739 to TYPO3 Core
  • Category changed from scheduler to scheduler
#12

Updated by Christian Kuhn over 3 years ago

  • Related to Feature #34227: Scheduler: Allow execution using "at"-daemon added
#13

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF