Bug #45360

TCA wizard "add": save/close leads to error message

Added by Roland over 6 years ago. Updated 2 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2013-02-11
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Saving/Closing of a record which was meant to be added via TCA wizard "add" leads to this error message:

No valid ajaxID parameter given.

I used this wizard-configuration im my TCA configuration:

'wizards' => array(
    '_PADDING' => 1,
    '_VERTICAL' => 1,
    'add' => Array(
        'type' => 'script',
        'title' => 'Create new',
        'icon' => 'add.gif',
        'params' => array(
            'table' => 'tx_accphyproduktkatalog_domain_model_feature',
            'pid' => '###CURRENT_PID###',
            'setValue' => 'prepend'
        ),
        'script' => 'wizard_add.php',
    ),
),

test.zip (17.5 KB) Roland , 2013-02-12 10:02

History

#1 Updated by Roland over 6 years ago

important to add: error only occurs if the field with the wizard is part of a IRRE record

  • parent record
    • irre record with a field which has an "add" wizard

#2 Updated by Thorsten Kahler over 6 years ago

  • Category changed from Backend User Interface to 978

#3 Updated by Roland over 6 years ago

i boiled it down to this specific scenario that causes the error message:

TCA configuration of the IRRE field: ['config']['appearance']['collapseAll'] => 1

with 'collapseAll' => 0 the error message will not whow up.

enclosed please find a test extension and have a look at line 114 in test/Configuration/TCA/Grandparent.php

#4 Updated by Michal Szostak over 5 years ago

This error still persists in version 6.1.5.

#5 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from 6.0.2 to 7.4 (Backend)
  • Is Regression set to No

#6 Updated by Susanne Moog almost 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#7 Updated by Benni Mack over 3 years ago

  • Target version deleted (7.5)

#8 Updated by Jonas Eberle 2 days ago

I cannot reproduce any more in v9 (with collapseAll => 0)

#9 Updated by Riccardo De Contardi 2 days ago

  • Status changed from New to Closed

A lot of time has passed since version 6.x; I think it is safe to close this one for now;

If you think that this is the wrong decision or have more information about how to reproduce this issue on recent TYPO3 versions like 8.7 or 9 or the latest master, please reopen it or ping me.

Thank you.

Also available in: Atom PDF