Project

General

Profile

Actions

Bug #45504

closed

Case sensitive filenames lead to file list problems

Added by TimoF no-lastname-given over 11 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2013-02-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

A customer of ours uploaded a file xyz.jpg and referenced it in several pages. Then he wanted to replace the file in the file list, uploaded a file xyz.JPG (with capital letters in the extension!) and checked "Overwrite existing files".

This seems to confuse TYPO3, as the file list now listed both files (because, of course, the UNIX file system distinguished the two files) but show the same references for both files (although the second file hasn't been referenced at all yet).


Related issues 4 (0 open4 closed)

Related to TYPO3 Core - Task #46553: Resolve issues with case-sensitive filesClosed2013-03-22

Actions
Related to TYPO3 Core - Bug #43027: Problems on case-sensitive filesystemsClosedAndreas Wolf2012-11-16

Actions
Related to TYPO3 Core - Bug #53575: Language module: Wrong argument passed to File::updateProperties()ClosedNicole Cordes2013-11-12

Actions
Related to TYPO3 Core - Task #53604: CleanUp Canonicalize and Unique Identifier in DriversClosedSteffen Ritter2013-11-13

Actions
Actions #1

Updated by Andreas Wolf over 11 years ago

  • Category set to File Abstraction Layer (FAL)
  • Status changed from New to Accepted

The relation issue is closely related to #43027. The other issue (file is not replaced if casing is different) should be new.

Actions #2

Updated by Alexander Opitz over 11 years ago

I do not understand, why should the file be overwritten if his casing is different?

Actions #3

Updated by TimoF no-lastname-given over 11 years ago

The problem is that TYPO3 shows the same references for both files (although the second file hasn't been referenced at all yet).

Actions #4

Updated by Chris topher almost 11 years ago

TimoF wrote:

The problem is that TYPO3 shows the same references for both files (although the second file hasn't been referenced at all yet).

Yes, I can confirm that error with TYPO3 6.1.1:

If you have one file, which you reference in an element, and then upload a file with the same name, but with different casing, then filelist incorrectly shows both(!) as referenced.

Actions #5

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #6

Updated by Gerrit Code Review over 10 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #7

Updated by Gerrit Code Review over 10 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #8

Updated by Gerrit Code Review over 10 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #9

Updated by Gerrit Code Review over 10 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #10

Updated by Gerrit Code Review over 10 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/23398

Actions #11

Updated by Andreas Wolf over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #12

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF