Bug #45799

feuser: Fields first_name/middle_name/last_name only if name shown as well

Added by Stefan Neufeind almost 8 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Could have
Category:
Backend User Interface
Target version:
-
Start date:
2013-02-24
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The field "name" was deprecated quite some while ago. It's suggested to use the separate fields and split the name. In the backend those fields are currently on the secondary palette. And they are only shown if the field "name" is shown as well.
But that leads to confusion with users having four name-fields then and not knowing were to fill in the name.

It would be great to decouple this if possible. Maybe still keep the three separate fields on the secondary palette as is (no change in behaviour) but to also show the fields if name is not shown (so not defining them as children of "name" I guess).

Tested with 4.5.22.


Related issues

Related to TYPO3 Core - Task #45807: fe_users: Deprecate combined "name"-fieldRejected2013-02-24

Actions
#1

Updated by Stefan Neufeind almost 8 years ago

I just stumbled across where I've come across the "deprecated" combined name-field. It's in tt_address (which is an optional extension), not in fe_users.
(Just checked: current master still has both the combined name-field and the separate ones.)

[disableCombinedNameField]
Check to disable the original tt_address name field after you updated your address records to the separate first, middle, and last name fields.

#2

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber
  • Is Regression set to No

I don't get the difference between the two tickets. Can't we combine them into one?

#3

Updated by Stefan Neufeind almost 6 years ago

If I remember right this one here is about what fields are shown when. If you disable the combined field (which isn't on the second palette), the three separate ones should show up on the first palette imho.

Showing four fields is irritating, so when "name" is shown we should imho keep the other three on the second palette.

#4

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New
#5

Updated by Daniel Goerz over 4 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Should have to Could have
  • TYPO3 Version changed from 4.5 to 8

On current master the secondary palette is always shown and the name field has a help text stating "Enter the regular name of the user, both first- and surname.". Stefan, is this "good enough" to close this ticket? Or do you still think this is a bug that should be fixed? Then please rephrase how you'd fix it. :)

#6

Updated by Riccardo De Contardi over 4 years ago

I think that the problem is still that showing four separate fields: "Name", "First name", "Middle name", "Surname" is confusing. What should be used? The first one? The other three? the CHS does not help that much IMO: ok, it says that "Name" is the combination of first name and last name, but should I write something in it? or not? Under what circumstances? Is it an alternative for the other fields?

#7

Updated by Alexander Opitz about 4 years ago

  • Status changed from Needs Feedback to New
#8

Updated by Mathias Schreiber 8 months ago

  • Status changed from New to Closed

Workaround for older versions:
Set the "name" field to "readonly", use the dedicated field from now on.

Also available in: Atom PDF