Bug #46250

Exception with EXT:sys_note is installed

Added by Mario Rimann over 8 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2013-03-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As soon as the system extension "sys_note" installed, the following exception is shown in the right column of the backend, whenever I open the page or list module:

 #1247602160: Table 'typo3-master.tx_extbase_domain_model_backenduser' doesn't exist:
SELECT tx_extbase_domain_model_backenduser.* FROM tx_extbase_domain_model_backenduser WHERE
tx_extbase_domain_model_backenduser.uid = '1' LIMIT 1 (More information)

Seems that the mapping for the BackendUser-Modul to the "be_users" table is not made within sys_note.

Disabling the extension solves the issue, re-enabling it brings the issue back, reproducable. Tested on 6.1-dev based on rev. 75ee5d8f209


Related issues

Has duplicate TYPO3 Core - Bug #51234: Exception with EXT:sys_note is installedClosedPhilipp Gampe2013-03-13

Actions
#1

Updated by Ernesto Baschny over 8 years ago

I've got far other problems with sys_note in master:

Fatal error: Call to a member function create() on a non-object in
.../html/typo3_src-master/typo3/sysext/extbase/Classes/Persistence/Generic/PersistenceManager.php
on line 363

Coming from the hook call in the page module to the sys_note:

14    0.9281    11593712    call_user_func_array ( )    ../ActionController.php:313
15 0.9281 11593964 TYPO3\CMS\SysNote\Controller\NoteController->listAction( ) ../ActionController.php:0
16 0.9892 11990148 TYPO3\CMS\SysNote\Domain\Repository\SysNoteRepository->findByPidsAndAuthor( ) ../NoteController.php:59
17 0.9893 11990416 TYPO3\CMS\Extbase\Persistence\Repository->createQuery( ) ../SysNoteRepository.php:55
18 0.9893 11990416 TYPO3\CMS\Extbase\Persistence\Generic\PersistenceManager->createQueryForType( ) ../Repository.php:268

So I am not able to reproduce your error yet, since I've got others first. :)

#2

Updated by Marcin Sągol over 8 years ago

I can confirm this error. Using latest git version (6.1-dev), PHP 5.4.

Table 'typo3.tx_extbase_domain_model_backenduser' doesn't exist: SELECT tx_extbase_domain_model_backenduser.* FROM tx_extbase_domain_model_backenduser WHERE tx_extbase_domain_model_backenduser.uid = '1' LIMIT 1

#3

Updated by Oliver Hader over 8 years ago

  • Category set to Backend API
  • Target version set to 4.5.26
#4

Updated by Oliver Hader over 8 years ago

  • Status changed from New to Accepted
#5

Updated by Oliver Hader over 8 years ago

  • Target version changed from 4.5.26 to 6.0.5
#6

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19134

#7

Updated by Oliver Hader over 8 years ago

Gerrit Code Review wrote:

Patch set 1 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19134

A less invasive way would be to extend BackendConfigurationManager::getTypoScriptSetup() in Extbase, check for 'config.extbase.' there and trigger the TypoScript parsing again, if not being available there.

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19134

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19134

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/19286

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/19134

#12

Updated by Oliver Hader over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Torben Hansen over 8 years ago

I still get this error message in the Backend with TYPO3 version 6.1.1

Everything worked fine for a while, but suddenly the described problem appeared.

Removing sys_note resolves the problem.

#14

Updated by Lukas no-lastname-given over 8 years ago

I can confirm this is error popping up again in 6.1.1. I'm not 100% sure whether sys_note has always been enabled on my site, but at some point the error suddenly started appearing. Disabling the module resolves the problem, but I'm seriously confused as to why this happens and what triggered it. The code from the patch for this issue is definitely present in my installation.

Please re-open this issue.

#15

Updated by Martin Holtz over 8 years ago

Lukas no-lastname-given wrote:

I can confirm this is error popping up again in 6.1.1. I'm not 100% sure whether sys_note has always been enabled on my site, but at some point the error suddenly started appearing. Disabling the module resolves the problem, but I'm seriously confused as to why this happens and what triggered it. The code from the patch for this issue is definitely present in my installation.

Please re-open this issue.

I guess it is cache related. I truncated all df_* tables and everything works fine again. FYI: i had the same error message in loggin-modul before clearing the cache-tables.

#16

Updated by Lukas no-lastname-given over 8 years ago

Martin Holtz wrote:

I guess it is cache related. I truncated all df_* tables and everything works fine again. FYI: i had the same error message in loggin-modul before clearing the cache-tables.

That seems to have done the trick indeed. But shouldn't that have been "cf_*"? And shouldn't the "Clear all caches" feature in the backend already do that?

#17

Updated by Martin Holtz over 8 years ago

Issue is still valid for 6.1.3

#18

Updated by Philipp Gampe over 8 years ago

This is a cache issue ... do you use the same instance for multiple versions of TYPO3 (git branches)?

#19

Updated by Lukas no-lastname-given over 8 years ago

I for one certainly don't. There's only one instance on my test system (to which I unfortunately don't have access right now since I'm working on another project).

#20

Updated by Martin Holtz over 8 years ago

It seems to be somehow a racecondition. After getting an error, i checked "cf_extbase_datamapfactory_datamap" for identifier "TYPO3%CMS%Extbase%Domain%Model%BackendUser".

I got the error message, if there is a serialized object where tableName ist set to "tx_extbase_domain_model_backenduser". After deleting that entry, i got an new entry with tableName "be_users".

I guess, that it happens f.e. if a scheduler job is executed and creates an wrong cache entry. But i am not able to reproduce this issue at the moment. It just happens sometimes.

The correct object has about 18k, the "wrong" only about 0.8k. So, there must be a situation, where the object is created with only a small subset of the information, which should be there.

#21

Updated by Martin Holtz over 8 years ago

With this serialized object i got the error messages:

O:52:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\DataMap":19:{s:12:"*className";s:42:"TYPO3\CMS\Extbase\Domain\Model\BackendUser";s:12:"*tableName";s:35:"tx_extbase_domain_model_backenduser";s:13:"*recordType";N;s:13:"*subclasses";a:0:{}s:13:"*columnMaps";a:0:{}s:19:"*pageIdColumnName";s:3:"pid";s:23:"*languageIdColumnName";N;s:30:"*translationOriginColumnName";N;s:29:"*modificationDateColumnName";N;s:25:"*creationDateColumnName";N;s:20:"*creatorColumnName";N;s:24:"*deletedFlagColumnName";N;s:25:"*disabledFlagColumnName";N;s:22:"*startTimeColumnName";N;s:20:"*endTimeColumnName";N;s:30:"*frontendUserGroupColumnName";N;s:23:"*recordTypeColumnName";N;s:11:"*isStatic";b:0;s:12:"*rootLevel";b:0;}

With this serialized object everything went fine:

O:52:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\DataMap":19:{s:12:"*className";s:42:"TYPO3\CMS\Extbase\Domain\Model\BackendUser";s:12:"*tableName";s:8:"be_users";s:13:"*recordType";N;s:13:"*subclasses";a:0:{}s:13:"*columnMaps";a:27:{s:8:"userName";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:8:"userName";s:13:"*columnName";s:8:"username";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:8:"password";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:8:"password";s:13:"*columnName";s:8:"password";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:9:"usergroup";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:9:"usergroup";s:13:"*columnName";s:9:"usergroup";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:12:"locktodomain";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:12:"locktodomain";s:13:"*columnName";s:12:"lockToDomain";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:13:"dbMountpoints";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:13:"dbMountpoints";s:13:"*columnName";s:14:"db_mountpoints";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:15:"fileMountpoints";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:15:"fileMountpoints";s:13:"*columnName";s:16:"file_mountpoints";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:5:"email";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:5:"email";s:13:"*columnName";s:5:"email";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:8:"realName";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:8:"realName";s:13:"*columnName";s:8:"realName";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:10:"isDisabled";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:10:"isDisabled";s:13:"*columnName";s:7:"disable";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:16:"ipLockIsDisabled";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:16:"ipLockIsDisabled";s:13:"*columnName";s:13:"disableIPlock";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:15:"isAdministrator";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:15:"isAdministrator";s:13:"*columnName";s:5:"admin";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:7:"options";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:7:"options";s:13:"*columnName";s:7:"options";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:13:"fileoperPerms";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:13:"fileoperPerms";s:13:"*columnName";s:14:"fileoper_perms";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:14:"workspacePerms";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:14:"workspacePerms";s:13:"*columnName";s:15:"workspace_perms";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:16:"startDateAndTime";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:16:"startDateAndTime";s:13:"*columnName";s:9:"starttime";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:14:"endDateAndTime";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:14:"endDateAndTime";s:13:"*columnName";s:7:"endtime";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:4:"lang";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:4:"lang";s:13:"*columnName";s:4:"lang";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:8:"usermods";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:8:"usermods";s:13:"*columnName";s:8:"userMods";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:16:"allowedLanguages";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:16:"allowedLanguages";s:13:"*columnName";s:17:"allowed_languages";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:8:"tsconfig";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:8:"tsconfig";s:13:"*columnName";s:8:"TSconfig";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:15:"createdbyaction";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:15:"createdbyaction";s:13:"*columnName";s:15:"createdByAction";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:20:"lastLoginDateAndTime";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:20:"lastLoginDateAndTime";s:13:"*columnName";s:9:"lastlogin";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:20:"ttNewsCategorymounts";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:20:"ttNewsCategorymounts";s:13:"*columnName";s:22:"tt_news_categorymounts";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:24:"txBesecurepwLastpwchange";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:24:"txBesecurepwLastpwchange";s:13:"*columnName";s:26:"tx_besecurepw_lastpwchange";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:25:"txCalEnableAccesscontroll";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:25:"txCalEnableAccesscontroll";s:13:"*columnName";s:28:"tx_cal_enable_accesscontroll";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:13:"txCalCalendar";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:13:"txCalCalendar";s:13:"*columnName";s:15:"tx_cal_calendar";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}s:13:"txCalCategory";O:54:"TYPO3\CMS\Extbase\Persistence\Generic\Mapper\ColumnMap":16:{s:15:"*propertyName";s:13:"txCalCategory";s:13:"*columnName";s:15:"tx_cal_category";s:17:"*typeOfRelation";s:13:"RELATION_NONE";s:17:"*childClassName";N;s:17:"*childTableName";N;s:27:"*childTableWhereStatement";N;s:23:"*childSortByFieldName";N;s:20:"*relationTableName";N;s:32:"*relationTablePageIdColumnName";N;s:27:"*relationTableMatchFields";N;s:28:"*relationTableInsertFields";N;s:30:"*relationTableWhereStatement";N;s:21:"*parentKeyFieldName";N;s:23:"*parentTableFieldName";N;s:20:"*childKeyFieldName";N;s:24:"*dateTimeStorageFormat";N;}}s:19:"*pageIdColumnName";s:3:"pid";s:23:"*languageIdColumnName";N;s:30:"*translationOriginColumnName";N;s:29:"*modificationDateColumnName";s:6:"tstamp";s:25:"*creationDateColumnName";s:6:"crdate";s:20:"*creatorColumnName";s:9:"cruser_id";s:24:"*deletedFlagColumnName";s:7:"deleted";s:25:"*disabledFlagColumnName";s:7:"disable";s:22:"*startTimeColumnName";s:9:"starttime";s:20:"*endTimeColumnName";s:7:"endtime";s:30:"*frontendUserGroupColumnName";N;s:23:"*recordTypeColumnName";s:5:"admin";s:11:"*isStatic";b:0;s:12:"*rootLevel";i:1;}

(i removed \0)

After deleting the first, i got the second. But every few days, we got that error again.

#22

Updated by Alban Cousinie over 8 years ago

This bug is also present in Typo3 6.1.3

#23

Updated by Philipp Gampe over 8 years ago

I reopened this as: #51234 please report your findings there.

#24

Updated by Riccardo De Contardi about 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF