Bug #47529

Regression in 4.7.11rc1: Invalid argument supplied for foreach() in class.tx_cms_layout.php line 404

Added by Lars no-lastname-given about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Since commit https://git.typo3.org/TYPO3v4/Core.git/commitdiff/f6d0567b1b53653d520cc3fb08de3a2e2de9de64 this warning appears for each empty column:

PHP Warning: Invalid argument supplied for foreach() in typo3_src-4.7.11rc1/typo3/sysext/cms/layout/class.tx_cms_layout.php line 404

Tested in 4.7.11rc1, PHP 5.3.22 with APC


Files


Related issues

Has duplicate TYPO3 Core - Bug #44540: PHP Warning in 6.0.1-dev if there are empty columns in Page ModuleClosedmost wanted2013-01-15

Actions
Follows TYPO3 Core - Bug #44470: Content elements in wrong column in page moduleClosedOliver Hader2013-01-13

Actions
#1

Updated by Chris topher about 8 years ago

  • Category set to 1394
  • Target version set to 4.7.11

This does not concern 4.6, but all other branches from 4.5 up to master. See #44470.

#2

Updated by Chris topher about 8 years ago

  • Subject changed from Warning in tx_cms_layout to Regression in 4.7.11rc1: Invalid argument supplied for foreach() in class.tx_cms_layout.php line 404
#3

Updated by Gerrit Code Review about 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/20164

#4

Updated by Gerrit Code Review about 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/20229

#5

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/20230

#6

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/20231

#7

Updated by Gerrit Code Review about 8 years ago

Patch set 5 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/20164

#8

Updated by Gerrit Code Review about 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/20232

#9

Updated by Oliver Hader about 8 years ago

  • Category changed from 1394 to Backend User Interface
  • Status changed from Under Review to Resolved
  • Target version changed from 4.7.11 to 4.5.26
  • % Done changed from 0 to 100
  • TYPO3 Version changed from 4.7 to 4.5
  • PHP Version set to 5.3
#10

Updated by Daniel Ostmann almost 8 years ago

This is still an issue in 4.7.14. I attached a screenshot. I occours, if i select a page without any content columns.

#11

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF