Bug #47529

Regression in 4.7.11rc1: Invalid argument supplied for foreach() in class.tx_cms_layout.php line 404

Added by Lars no-lastname-given about 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-04-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Since commit https://git.typo3.org/TYPO3v4/Core.git/commitdiff/f6d0567b1b53653d520cc3fb08de3a2e2de9de64 this warning appears for each empty column:

PHP Warning: Invalid argument supplied for foreach() in typo3_src-4.7.11rc1/typo3/sysext/cms/layout/class.tx_cms_layout.php line 404

Tested in 4.7.11rc1, PHP 5.3.22 with APC


Files


Related issues

Has duplicate TYPO3 Core - Bug #44540: PHP Warning in 6.0.1-dev if there are empty columns in Page ModuleClosedmost wanted2013-01-15

Actions
Follows TYPO3 Core - Bug #44470: Content elements in wrong column in page moduleClosedOliver Hader2013-01-13

Actions

Also available in: Atom PDF