Bug #49476

Epic #61834: Create future proof Content Element with strong default

Task #61836: Reorganize Content Element properties within backend Extension

Task #61842: Refactor CSS-Styled-Content + Content Elements

css_styled_content borderThick could not be set to 0

Added by Bernd Niehues about 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2013-06-27
Due date:
% Done:

50%

TYPO3 Version:
6.1
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the max image width would be calculated wrong when setting the borderThick to a value of 0.

bug_49476.diff View (842 Bytes) Bernd Niehues, 2013-06-27 17:58

History

#1 Updated by Bernd Niehues about 6 years ago

#2 Updated by Jigal van Hemert about 6 years ago

  • Status changed from New to Needs Feedback

The property "borderThick" is only used if the property "border" evaluates to 1. To have no border you simply set "border" to zero.

Does this solve the issue?

#3 Updated by Bernd Niehues about 6 years ago

Setting the border property to zero ( border = 0 ) doesn't work. But unsetting in completly ( border > ) does work.

tt_content.image.20 {
borderThick = 0
border >
}

Thx!

#4 Updated by Alexander Opitz almost 6 years ago

  • Is Regression set to No

So we can close this issue?

#5 Updated by Bernd Niehues almost 6 years ago

May ne closed... But i think it would ne nicer to be able to unset the border also by setting it to zero?!

#6 Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to New
  • % Done changed from 100 to 50

#7 Updated by Felix Kopp almost 5 years ago

  • Parent task set to #61842

#8 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from next-patchlevel to 7.2 (Frontend)

#9 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)

#10 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#11 Updated by Benni Mack almost 4 years ago

  • Target version changed from 7.5 to 7 LTS

#12 Updated by Mathias Schreiber almost 4 years ago

  • Status changed from New to Closed

won't fix since we are moving towards Fluid Rendering

Also available in: Atom PDF