Bug #50908

loading indicator on save

Added by Pascal Dürsteler about 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I think there should be a loading indicator then pressing the save button on the doc header row. Other pages also display somehow that there is processing going on, either by the default indicator from the browser on a page change, or by the TYPO3 loading indicator displayed. Both is missing here.

Also applies to 6.1

#1

Updated by Mathias Schreiber over 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber
  • Is Regression set to No

Hi Pascal,

can you check if you like the way better how current master (7.1-dev) does it?
We have an orange loading bar indicator at the top of each form.

#2

Updated by Stefan Neufeind over 6 years ago

Hmm, I tried against current master. I know I saw the orange indicator somewhere, but currently don't see it upon save in any of:
  • form-wizard (which this ticket refers to)
  • content-element
  • page-record
#3

Updated by Alexander Opitz over 6 years ago

@Stefan Neufeind

Did you try on TYPO3 CMS 7?

#4

Updated by Bjoern Jacob over 6 years ago

  • Category changed from Form Framework to 1602
#5

Updated by Bjoern Jacob over 6 years ago

  • Category changed from 1602 to Form Framework
#6

Updated by Bjoern Jacob about 6 years ago

  • Category deleted (Form Framework)
  • Start date deleted (2013-08-08)
  • TYPO3 Version changed from 4.7 to 7

When loading or saving a page, tt_content element or the form wizard I don't see any orange loading indicator. I can see it while swichting the backend modules.

The current master is unbelievable fast. Maybe I can't see it because there is no need/ time to load and show the indicator.

I'm removing the category "Form Wizard" since this issue is kind of more general. And I've changed the TYPO3 version to 7.x. 4.7 is not supported anymore and it would be a feature in 6.x.

#7

Updated by Alexander Opitz almost 6 years ago

  • Assignee changed from Mathias Schreiber to Bjoern Jacob
  • TYPO3 Version changed from 7 to 4.7

Hi Björn,

please don't change the TYPO3 Version .. as the issue firstly was seen in this. :)
Yes it won't be fixed there and also for 6.2 there won't be changes. But for TYPO3 7 I don't have an issue here. So can you please check this with latest version (7.5 or 7.6-dev from master)?

#8

Updated by Andreas Fernandez almost 6 years ago

The current TYPO3 version 7.6 shows a spinner after clicking the save button. Is this sufficient for you?

#9

Updated by Pascal Dürsteler almost 6 years ago

Not that I have much to say, but for me, this is very sufficient.

#10

Updated by Stefan Neufeind almost 6 years ago

  • Status changed from Needs Feedback to Resolved

So this is resolved with TYPO3 CMS 7 LTS then. Thanks.

#11

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF