Bug #52629

Tx_Workspaces_Service_Fehooks corrupts page output

Added by David Gurk almost 6 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-03-02
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

The hook_eofe() inside Workspaces extension don't respect TypoScript setup with "config.admPanel = 0".

The situation:
- I have 2 pages.
- "Page A" has an active admin panel with an active simulated date.
- "Page B" has a TypoScript setup with "page.config.admPanel = 0".

The problem:
- In the HTML from "Page B", the content (script-tag) from typo3_src-4.7.15/typo3/sysext/workspaces/Resources/Private/Templates/Preview/Preview.html is rendered.
- This unnecessary code can break javascript.

A Solution?
Within typo3_src-4.7.15/typo3/sysext/workspaces/Classes/Service/Fehooks.php the admin panel visibility state should be respected. Maybe with a condition similar to this?

$tsfeBeUserAuth = t3lib_div::makeInstance('t3lib_tsfeBeUserAuth');
if(!$tsfeBeUserAuth->isAdminPanelVisible()) {
    return;
}

Hope for your help and a fix for the next update. =)

Best regards,

David


Related issues

Related to TYPO3 Core - Epic #84044: Admin Panel Rework Closed 2010-08-11

History

#1 Updated by Michael Stucki almost 6 years ago

  • Category changed from Bugs to Workspaces

#2 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#3 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.4 (Backend)
  • Is Regression set to No

#4 Updated by David Gurk over 4 years ago

It seems that the new Class typo3_src-6.2.9/typo3/sysext/workspaces/Classes/Hook/TypoScriptFrontendControllerHook.php has a check:

if ($pObj->fePreview != 2) {
    return;
}

BUT I can recreate the behaviour explained in the initial description. The content of typo3_src-6.2.9/typo3/sysext/workspaces/Resources/Private/Templates/Preview/Preview.html is still present, while admin panel is disabled.

#5 Updated by Mathias Schreiber over 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#6 Updated by Oliver Hader almost 4 years ago

  • Target version changed from 7.5 to 7 LTS
  • Complexity set to medium

#7 Updated by Mathias Schreiber almost 4 years ago

  • Target version deleted (7 LTS)

#8 Updated by Susanne Moog over 1 year ago

#9 Updated by Benni Mack 6 months ago

  • Status changed from New to Rejected

Workspace Preview + Admin Panel is now completely decoupled since TYPO3 v9.

If this breaks your javascript code, it is safe to assume that you can override or unset the preview functionality of workspaces in a custom extension.

Also available in: Atom PDF