Bug #54093

'l10n_display' => 'defaultAsReadonly' not working with mm table

Added by Thomas Christiansen about 8 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
Start date:
2013-11-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hey folks,
in my TCA I have a field of type select with an mm relation.

I am using 'l10n_mode' => 'exclude' and 'l10n_display' => 'defaultAsReadonly' and I would expect to see all the relations of the original record in my translated one, too.
Instead I get only one entry in the select field. Exactly that one with the id of how many relations are in the original record.
This is propably because the mm relation is not resolved in the translated record, but the value of the mm-field of the original record is taken (which is the count of relations).

For now i am not using l10n_display anymore, only l10n_mode.

Thanks and regards,
Thomas


Files


Related issues

Related to TYPO3 Core - Bug #75981: Timing of content elements in other languages not allowed (tt_content, l10n_display, defaultAsReadonly)Closed2016-04-29

Actions
Related to TYPO3 Core - Bug #91852: 'l10n_display' => 'defaultAsReadonly' not working with mm tableClosed2020-07-23

Actions
#1

Updated by Mathias Schreiber almost 7 years ago

  • Target version set to 7.4 (Backend)
#2

Updated by Susanne Moog over 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#3

Updated by Benni Mack about 6 years ago

  • Target version changed from 7.5 to 7 LTS
#4

Updated by Georg Ringer over 1 year ago

see screenshot, working now

#5

Updated by alejandro antolinez over 1 year ago

  • Related to Bug #91852: 'l10n_display' => 'defaultAsReadonly' not working with mm table added

Also available in: Atom PDF